Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Fwd: Problem with Bioportal display

Natasha Noy noy at stanford.edu
Mon Feb 2 17:58:01 PST 2009


Melanie,

Thank you for submitting the new version -- yes, it looks much better.  
Tim will be in touch with Alan and you directly to see what should be  
fixed on the Protege side (and BioPortal can pick it up from there).

There is now only one 1.0.1213 version.

We will remove the first of the 1.0.1423 versions. That should clean  
up all the duplicates.

We are pretty confident that a "remote" version won't be pulled  
overnight from obo foundry, but we will verify first thing in the  
morning.

The reason you were getting an error was probably because we were  
pushing out some new code. The main fix (should make Alan much  
happier, we hope:) -- we are now showing the full original url (as a  
link) in the Details page. That's your purls...

We will try to do some cosmetic changes, too.  Hopefully, tonight.

Thank you very much for your patience and all the feedback.

Natasha


On Feb 2, 2009, at 5:52 PM, Melanie Courtot wrote:

> Hi all,
>
> I did upload a new version this afternoon, stripped of duplicate  
> annotation properties. It just finished parsing and seems ok  
> regarding annotations display - see http://bioportal.bioontology.org/visualize/39317/OBI_0100016
>
> Few comments:
> - some of the 1.0.1213 extra versions have bee removed, but there  
> are still 2 of them remaining
> - could you delete the first 1.0.1423 which is now unnecessary?
>
> We had small issues when trying to log-in/upload a new version, when  
> submitting the forms (either Alan or myself on 2 different computers  
> and with 2 usernames/passwords), the error message after hitting  
> "submit" read "There is no data to support this query at this time."
>
> Thanks for your help,
> Melanie
>
>
>
> On Mon, Feb 2, 2009 at 4:26 PM, Timothy Redmond  
> <tredmond at stanford.edu> wrote:
>
> > So during imports, there is one label that is picked up from iao.owl
> > and a second (which is exactly the same) picked up by
> > ontology-metadata.owl. I have removed the ones in iao.owl.
>
> Yes - your description is pretty much right on.  Protege is ignoring  
> some of the owl:Ontology declarations which it should be using to  
> determine the names of the imported ontologies.  After that imported  
> data started to get lost.
>
> I have debugged this and Tania fixed it in the latest svn.  It is a  
> pure and simple Protege bug and it made a mess of your imported  
> assertions.  I think that you can just drop and use the attached  
> protege-owl.  For this style of ontology this is an important fix.
>
> -Timothy
>
>
> ----- Original Message -----
> From: "Alan Ruttenberg" <alanruttenberg at gmail.com>
> To: "Trish Whetzel" <whetzel at stanford.edu>
> Cc: "Melanie Courtot" <mcourtot at gmail.com>, bioontology-support at mailman.stanford.edu 
> , "Timothy Redmond" <tredmond at stanford.edu>
> Sent: Monday, February 2, 2009 3:15:34 PM GMT -08:00 US/Canada Pacific
> Subject: Re: [bioontology-support] Fwd: Problem with Bioportal display
>
> Ok. I see what is happening. The labels are defined in
>
> http://purl.obofoundry.org/obo/iao/2009-01-23/iao.owl and in
> http://purl.obofoundry.org/obo/iao/2009-01-23/ontology-metadata.owl
>
> iao.owl is imported by obi.owl
>
> So during imports, there is one label that is picked up from iao.owl
> and a second (which is exactly the same) picked up by
> ontology-metadata.owl. I have removed the ones in iao.owl.
>
> However this behavior really should be fixed in protege. (Tim?)
>
> There may be other duplications in the OBI.owl file proper - Melanie
> can answer that.
>
> -Alan
>
> On Mon, Feb 2, 2009 at 3:05 PM, Trish Whetzel <whetzel at stanford.edu>  
> wrote:
> > Hi Alan,
> >
> > Since the import processing is based on Protégé itself that  
> question would
> > be best for Tim or Tania.
> >
> > Trish
> >
> >
> >>-----Original Message-----
> >>From: Alan Ruttenberg [mailto:alanruttenberg at gmail.com]
> >>Sent: Monday, February 02, 2009 2:43 PM
> >>To: Trish Whetzel
> >>Cc: Melanie Courtot; bioontology-support at mailman.stanford.edu
> >>Subject: Re: [bioontology-support] Fwd: Problem with Bioportal  
> display
> >>
> >>Hi Trish,
> >>
> >>I'm doing some further investigation. Some of the duplication is  
> being
> >>generated via imports. Is there a description of the imports
> >>processing that bioportal is doing that I could get?
> >>
> >>-Alan
> >>
> >>On Mon, Feb 2, 2009 at 1:33 PM, Trish Whetzel <whetzel at stanford.edu>
> >>wrote:
> >>> Yes, that was clear. Thanks.
> >>>
> >>> On Feb 2, 2009, at 1:14 PM, Alan Ruttenberg <alanruttenberg at gmail.com 
> >
> >>> wrote:
> >>>
> >>>> Yes, I will. I was pointing out that the current behavior (with  
> the
> >>>> file you don't want) is incorrect. I wasn't sure whether that was
> >>>> clear. Is it?
> >>>> -Alan
> >>>>
> >>>> On Mon, Feb 2, 2009 at 12:40 PM, Trish Whetzel <whetzel at stanford.edu 
> >
> >>>> wrote:
> >>>>>
> >>>>> I thought that you were going to upload a file that did not  
> have the
> >>>>> replicated information?
> >>>>>
> >>>>> Trish
> >>>>>
> >>>>>
> >>>>>> -----Original Message-----
> >>>>>> From: Alan Ruttenberg [mailto:alanruttenberg at gmail.com]
> >>>>>> Sent: Monday, February 02, 2009 12:03 PM
> >>>>>> To: Trish Whetzel
> >>>>>> Cc: Melanie Courtot; bioontology-support at mailman.stanford.edu
> >>>>>> Subject: Re: [bioontology-support] Fwd: Problem with Bioportal
> >>display
> >>>>>>
> >>>>>> It shouldn't write "definition" more than once no matter how  
> many
> >>times
> >>>>>> one has
> >>>>>>
> >>>>>> OBI_XXXXX rdfs:label "definition".
> >>>>>>
> >>>>>> If I write
> >>>>>>
> >>>>>>
> >>>>>> OBI_XXXXX rdfs:label "definition".
> >>>>>> OBI_XXXXX rdfs:label "definition".
> >>>>>> OBI_XXXXX rdfs:label "definition".
> >>>>>> OBI_XXXXX rdfs:label "definition".
> >>>>>>
> >>>>>> There is still really only one triple.
> >>>>>> -Alan
> >>>>>>
> >>>>>>
> >>>>>> On Mon, Feb 2, 2009 at 12:01 PM, Trish Whetzel
> >><whetzel at stanford.edu>
> >>>>>> wrote:
> >>>>>>>
> >>>>>>> Hmm, buggy in what way? Is {definition, defintion} still  
> displayed
> >>>>>>
> >>>>>> with the
> >>>>>>>
> >>>>>>> added annotation files removed?
> >>>>>>>
> >>>>>>> Trish
> >>>>>>>
> >>>>>>>
> >>>>>>>> -----Original Message-----
> >>>>>>>> From: Alan Ruttenberg [mailto:alanruttenberg at gmail.com]
> >>>>>>>> Sent: Monday, February 02, 2009 11:59 AM
> >>>>>>>> To: Trish Whetzel
> >>>>>>>> Cc: Melanie Courtot; bioontology-support at mailman.stanford.edu
> >>>>>>>> Subject: Re: [bioontology-support] Fwd: Problem with  
> Bioportal
> >>display
> >>>>>>>>
> >>>>>>>> We can, however the behavior is still buggy in P3. An RDF  
> graph
> >>is a
> >>>>>>>> set of triples, not a multi-set.
> >>>>>>>> Of course the behavior of P4 is *also* buggy. Sigh...
> >>>>>>>> -Alan
> >>>>>>>>
> >>>>>>>> http://en.wikipedia.org/wiki/Multiset
> >>>>>>>>
> >>>>>>>> On Mon, Feb 2, 2009 at 11:35 AM, Trish Whetzel
> >><whetzel at stanford.edu>
> >>>>>>>> wrote:
> >>>>>>>>>
> >>>>>>>>> Hi Alan and Melanie,
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Can a new OBI file be uploaded that does not have the
> >>definitions
> >>>>>>>>
> >>>>>>>> added to
> >>>>>>>>>
> >>>>>>>>> all the files, ie the change that Alan made for p4?  
> BioPortal
> >>uses
> >>>>>>>>
> >>>>>>>> Protégé
> >>>>>>>>>
> >>>>>>>>> 3.4.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Thanks,
> >>>>>>>>>
> >>>>>>>>> Trish
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> From: bioontology-support-bounces at lists.stanford.edu
> >>>>>>>>> [mailto:bioontology-support-bounces at lists.stanford.edu] On
> >>Behalf Of
> >>>>>>>>
> >>>>>>>> Trish
> >>>>>>>>>
> >>>>>>>>> Whetzel
> >>>>>>>>> Sent: Saturday, January 31, 2009 9:56 AM
> >>>>>>>>> To: bioontology-support at lists.stanford.edu
> >>>>>>>>> Subject: [bioontology-support] Fwd: Problem with Bioportal
> >>display
> >>>>>>>>> Begin forwarded message:
> >>>>>>>>>
> >>>>>>>>> From: Alan Ruttenberg <alanruttenberg at gmail.com>
> >>>>>>>>> Date: January 31, 2009 8:56:12 AM PST
> >>>>>>>>> To: Trish Whetzel <plwhetzel at gmail.com>, Benjamin Dai
> >>>>>>>>> <benjamin.dai at stanford.edu>
> >>>>>>>>> Cc: Melanie Courtot <mcourtot at gmail.com>
> >>>>>>>>> Subject: Problem with Bioportal display
> >>>>>>>>>
> >>>>>>>>> http://bioportal.bioontology.org/visualize/39300/IAO_0000018
> >>>>>>>>>
> >>>>>>>>> Note that labels are repeated.
> >>>>>>>>> Regardless of whether the label statement is asserted in  
> more
> >>than
> >>>>>>
> >>>>>> one
> >>>>>>>>>
> >>>>>>>>> file, identical triples are considered one, and so duplicate
> >>labels
> >>>>>>>>> should never appear. In all cases, in a logical  
> expression, only
> >>a
> >>>>>>>>> single label should be shown. Should there be more than  
> one, a
> >>>>>>
> >>>>>> tooltip
> >>>>>>>>>
> >>>>>>>>> can supply further information.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> I recall that annotation properties were added in
> >>>>>>
> >>>>>> duplicate/triplicate
> >>>>>>>>
> >>>>>>>> in
> >>>>>>>>>
> >>>>>>>>> this release of OBI. In the email to the obi-devel list  
> titled
> >>>>>>>>
> >>>>>>>> Rendering
> >>>>>>>>>
> >>>>>>>>> Problem:
> >>>>>>>>>
> >>>>>>>>> Caused by me. Possible lesser of two evils. p4 doesn't  
> like it
> >>if
> >>>>>>
> >>>>>> the
> >>>>>>>>>
> >>>>>>>>> annotation properties aren't defined in the file that uses  
> them.
> >>So
> >>>>>>
> >>>>>> I
> >>>>>>>>>
> >>>>>>>>> added definitions to all the files. I've been debugging
> >>performance
> >>>>>>>>> and this was done while doing so. I can get rid of them,  
> but if
> >>it's
> >>>>>>>>> not too much trouble I'd prefer to leave them. It's a bug  
> that
> >>>>>>
> >>>>>> protege
> >>>>>>>>>
> >>>>>>>>> displays the same thing more than once though.
> >>>>>>>>> -Alan
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> As follow-up I have reviewed OBI in both Protégé 3.4 build  
> 519
> >>and
> >>>>>>>>
> >>>>>>>> Protégé
> >>>>>>>>>
> >>>>>>>>> 4. In Protégé 4, the labels are not repeated, however in  
> Protégé
> >>3.4
> >>>>>>>>
> >>>>>>>> they
> >>>>>>>>>
> >>>>>>>>> are, ie {definition, definition}. I have reported this as  
> a bug
> >>with
> >>>>>>>>> BioPortal (Bug #1043). Alan, did you report this on the  
> Protégé
> >>>>>>>>
> >>>>>>>> mailing
> >>>>>>>>>
> >>>>>>>>> list?
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>
> >>>>>
> >>>
> >
> >
>
> _______________________________________________
> bioontology-support mailing list
> bioontology-support at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/bioontology-support




More information about the bioontology-support mailing list