Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] [POSSIBLE VIRUS:###] adding SNOMED to annotation dictionary

Madani,Sina AHMadani at
Tue Dec 21 07:48:47 PST 2010

Hi Paul,
I did a clean-up and re ran the process for SNOMED. The Process started on Friday afternoon. By Saturday concept process was finished and relationship process lasted from Saturday afternoon until Tuesday morning.
I wasn't monitoring sql tables in my first attempt and just relied on the response from the browser (like I did for ICD-9 and ICD-10). So when I saw "done" I thought it was finished and after that I made multiple start-ups. I guess that was the reason you saw multiple misconnections in my log.

The only error that happened this time was some IO communication errors. After the status showed "28" for SNOMED I tried to do the last step for adding the dictionary but got no-response from the server. So I did a httpd service restart and the dictionary call worked.
Anyway, it seems that the annotation is working with SNOMED. Thanks again for all your help.

I am now troubleshooting NCI Thesaurus OWL file parsing error. I thought I can fix it by loading the recommended format (xml). That was why I  switched to OWL (inferred version). I'll email you with my findings


From: Madani,Sina
Sent: Friday, December 17, 2010 10:38 AM
To: 'Paul R Alexander'
Cc: support
Subject: RE: [POSSIBLE VIRUS:###] adding SNOMED to annotation dictionary

Well, I ran all the steps as noted in the instruction from 1-4 (removing old, adding new, loaderbigconcept and loaderbigpath) through rest calls, and finally creating dictionary, each took less than 10 minutes when I get "done" in the browser. So I thought the process was finished and did a ncborestart. Also I restarted the instance a couple of times.
Today for the first time (after searching for sql user passwords for schema names) I was able to look at obs_ontology tables.  Apparently adding SNOMED to annotation tables was never finished. I was going to execute the cleaning queries but perhaps I should wait since the status is showing 13 now? If it gets to 14 then I re-run loaderbigpaths or it will automatically does that since I think a did that call a couple of times since yesterday. Also, as you mentioned each time that I am adding a new ontology I use "all" instead of each ontology ID in the rest calls.


[cid:image001.png at 01CBA0F3.6CC332A0]

From: Paul R Alexander [mailto:palexander at]
Sent: Friday, December 17, 2010 12:45 AM
To: Madani,Sina
Cc: support
Subject: Re: [POSSIBLE VIRUS:###] adding SNOMED to annotation dictionary


According to the logs it looks as though the application server is starting and stopping repeatedly. What steps are you taking to produce this behavior? Since these are long ontologies, I would expect for the processing to take a very long time, perhaps even a day or more (I would need to check on this to be sure, but it sounds plausible).


On 12/16/10 9:12 AM, Madani,Sina wrote:
Hi Paul,

I was able to successfully load SNOMED after increasing disk 2 and 3 from 8Gb to 30Gb each. I have only ICD9 & 10 and SNOMED and almost half the new space if full.
I followed the same instruction for adding SNOMED to the dictionary and annotator services but it's not showing up in the list of available ontologies for annotation. It only shows ICD9 and 10
I attached my catalina log file in case it's useful for troubleshooting.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 23057 bytes
Desc: image001.png
URL: <>

More information about the bioontology-support mailing list