Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Problem with subtreerootconceptid in REST request

Dan Bolser dan.bolser at gmail.com
Wed Nov 21 14:20:20 PST 2012


Many thanks Trish!

Obviously, the sooner the better, but it isn't really holding me
back... I'm querying BioPortal for terms as part of a process to map
my database onto EDAM. I have a report on the terms used in my
database and the corresponding EDAM terms here:
http://seqanswers.com/wiki/Ontology:EDAM#REPORT

The EDAM term matches are all looked up via BioPortal REST services.
The issue is that these terms (the field in my DB from which these
terms arise) are all roughly 'topics', however, some of them match
other branches of the ontology, and I end up picking an EDAM ID at
random from the matches. There is a possibility that I could pick the
right term by using better XPATH over the query result, but since I
had read about subtreerootconceptid I decided to try that first
(especially as my XPATH skills are weak ;-)

Thanks again for help confirming this issue.


All the best,
Dan.

On 21 November 2012 22:11, Trish Whetzel <whetzel at stanford.edu> wrote:
> Hi Dan,
>
> As best I can tell, there appears to be a bug when including the "subtreerootconceptid" parameter in that the searchBean information is not returned, i.e. the actual search results. When changing the param "isexactmatch" from true to false the value of "numHitsTotal" changes from 3 to 212 but with no actual results returned and I've tried this call with previous examples that now also do not return the actual search results.
>
> I'll submit a bug report on this issue. To help prioritize, can you provide a few details on the effect of this issue on your project, e.g. can not move forward with project or can wait a few weeks for this to be resolved.
>
> Trish
>
>
> On Nov 21, 2012, at 1:23 PM, Dan Bolser wrote:
>
>> Hi,
>>
>> I'm trying to do a REST search with subtreerootconceptid [1] because
>> my search term 'Alignment' matches several branches of the EDAM
>> ontology. For example:
>> http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment
>>
>> Returns the following three concepts:
>> * EDAM_data:1916
>> * EDAM_topic:0083
>> * EDAM_operation:2928
>>
>> In this particular search, I only want to return concepts in the
>> 'topic' branch of the EDAM ontology, so I'm trying the following (and
>> various permutations thereof):
>> http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment&subtreerootconceptid=EDAM_topic%3A0003
>>
>> Nothing I've tried seems to work, returning zero hits instead of the
>> previous three. This seems to be the right way to specify the 'topic'
>> branch, being the subtree of the topic node:
>> http://bioportal.bioontology.org/ontologies/47814/?p=terms&conceptid=EDAM_topic%3A0003
>>
>> Am I doing something wrong?
>>
>>
>> Many thanks for any suggestions,
>> Dan.
>>
>> [1] http://www.bioontology.org/wiki/index.php/BioPortal_REST_services#Search_BioPortal
>> _______________________________________________
>> bioontology-support mailing list
>> bioontology-support at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/bioontology-support
>


More information about the bioontology-support mailing list