Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] virtual appliance population workflow problem

Ray Fergerson ray.fergerson at stanford.edu
Mon Jun 17 12:13:42 PDT 2013


I'm unclear about what exactly you have done. Have you added the ontology
to the appliance version of BioPortal? If not then you need to do this
first. Then you need to (re)run the annotation hierarchy and the resource
index update processes for this ontology to be available for annotation
and resource search. Note that I believe that the resource index
population relies on the annotation hierarchy population process already
having been run.

 

Ray

 

From: bioontology-support-bounces at lists.stanford.edu
[mailto:bioontology-support-bounces at lists.stanford.edu] On Behalf Of
Nikolina Koleva
Sent: Monday, June 17, 2013 6:19 AM
To: bioontology-support at lists.stanford.edu
Subject: [bioontology-support] virtual appliance population workflow
problem

 

 

Dear Trish Whetzel and all,

 

I tried to execute the workflow for populating for the ncbo appliance as
it is described on:

 

http://www.bioontology.org/wiki/index.php/Resource_Index_Dataset_Workflow_
Howto

 

after fixing some pointers in the build.properties file, the listed
commands are working without getting errors.

 

I tried to add one ontology (GEO) or all of them
(GEO,AE,CT,GM,OMIM,CDD,PGDI,PGDR,PGGE,REAC,RXRD,UPKB,WP,BSM,DBK,SMD,CANANO
,PC,PCM,GAP,MICAD,PM,AERS,GRANTS)

but in either cases the problem is that no ontology has been found among
those.

The message that I am getting is: 

 

2013-06-17 05:56:13,423 - Populating obs slave tables starts 

2013-06-17 05:56:14,007 - Population of slave data from master obs
database started. 

2013-06-17 05:56:14,211 - Number of ontologies added :0 

2013-06-17 05:56:14,212 - Number of ontologies added :0 

2013-06-17 05:56:14,212 - Number of ontology entries added in slave
ontology table : 0 

2013-06-17 05:56:14,212 - No new ontology found in master table. 

2013-06-17 05:56:14,212 - Population of slave data from master obs
database completed. 

2013-06-17 05:56:14,212 - Population of slave data processed in : 00
hours, 00 minutes, 00 seconds. 

org.ncbo.stanford.obr.exception.NoOntologyFoundException: No new ontology
found

          at
org.ncbo.stanford.obr.service.obs.impl.ObsDataPopulationServiceImpl.popula
teObsSlaveData(ObsDataPopulationServiceImpl.java:85)

          at
org.ncbo.stanford.obr.service.workflow.impl.ResourceIndexWorkflowImpl.popu
lateObsSlaveTables(ResourceIndexWorkflowImpl.java:81)

          at
org.ncbo.stanford.obr.populate.main.PopulateResourceIndex.main(PopulateRes
ourceIndex.java:33)

 

I would appreciate any ideas on what the problem might be.

 

Once this works a further question is if there is an automatic way to
include other ontologies that are contained in BioPortal.

 

Best regards,

Nikolina Koleva

 

 

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/bioontology-support/attachments/20130617/f9a166ae/attachment.html>


More information about the bioontology-support mailing list