Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Issues bringing up the NCBO Virtual Appliance: mgrep does not start

Kyle Reynolds kyle.reynolds at jhu.edu
Mon Mar 11 11:05:32 PDT 2013


FYI, I took a look for the log and there was nothing there. The directory structure exists, but no production log was created yet.
-Kyle

From: Paul R Alexander [mailto:palexander at stanford.edu]
Sent: Monday, March 11, 2013 12:59 PM
To: Stephen Granite
Cc: 'Trish Whetzel'; ksr at jhu.edu; 'NCBO User Support'
Subject: Re: [bioontology-support] Issues bringing up the NCBO Virtual Appliance: mgrep does not start

Unfortunately, I cannot reproduce either the error you get when creating an account or the error you get when trying to view the API key. Here is the log location on the Appliance. If you can see an error there I may be able to help figure it out:
/var/log/rails/BioPortal/production.log

There is also a workaround. You can authorize an account using the REST service:
http://{your<http://%7byour> appliance IP or domain}:8080//bioportal/auth?username={your username}&password={your password}&apikey=11111111-9dd1-11e0-a996-115056bd0024

Just replace the brackets with your information. The API key in the URL is the one included on the Appliance by default.

Paul


On Mar 11, 2013, at 6:53 AM, "Stephen Granite" <sgranite at jhu.edu<mailto:sgranite at jhu.edu>> wrote:


Trish,

In order for us to load ontologies in, I need an API key for both Bioportal and the appliance here.  As I said before, the account here exists.  However, when I go to get the API key, I receive the same message I got when I tried to make the account in the first place: We're sorry but something has gone wrong. We have been notified of this error.

What should we be checking for regarding this?  Is this meant to spool out in an error log somewhere?

Stephen J. Granite, MS, MBA
Director of Database and Software Development
Center for Cardiovascular Bioinformatics and Modeling
Institute for Computational Medicine
The Johns Hopkins University
3400 North Charles Street
Hackerman Hall 312
Baltimore, MD 21218-2686
phone: 410-516-8849
fax: 410-516-5294

From: Trish Whetzel [mailto:whetzel at stanford.edu<http://stanford.edu>]
Sent: Friday, March 08, 2013 5:11 PM
To: Stephen Granite
Cc: 'Paul R Alexander'; 'NCBO User Support'; ksr at jhu.edu<mailto:ksr at jhu.edu>
Subject: Re: Issues bringing up the NCBO Virtual Appliance: mgrep does not start

Yes, however I do not know if that was a one-time submit web service error or a general bug in the create new user function included in that release.

Trish


On Mar 8, 2013, at 9:05 AM, Stephen Granite wrote:



Trish and Paul,

On a tangential note, I had tried to make an account in the BioPortal instance, but the interface said there was an error.  However, when I tried to make the same account again, the interface came back saying that the account in error existed.  I was then able to sign in with the account.  Does that make sense?

Stephen J. Granite, MS, MBA
Director of Database and Software Development
Center for Cardiovascular Bioinformatics and Modeling
Institute for Computational Medicine
The Johns Hopkins University
3400 North Charles Street
Hackerman Hall 312
Baltimore, MD 21218-2686
phone: 410-516-8849
fax: 410-516-5294

From: Trish Whetzel [mailto:whetzel at stanford.edu]
Sent: Friday, March 08, 2013 11:58 AM
To: Stephen Granite; Paul R Alexander
Cc: NCBO User Support; ksr at jhu.edu<mailto:ksr at jhu.edu>
Subject: Re: Issues bringing up the NCBO Virtual Appliance: mgrep does not start

Mgrep is used by the Annotator, however I do not know if having this start successfully is dependent on having ontologies populated in the Annotator database. Have you also populated ontologies in the Annotator database? As for the dependency, Paul can you comment on this?

Trish


On Mar 8, 2013, at 5:57 AM, Stephen Granite wrote:




In the CVRG, we are interested in bringing up an instance of the NCBO applicance, to serve as a sandbox for ontologies we develop, to harden them prior to submission to NCBO.  We downloaded a copy of the version 1.0 OVF and were able to get the BioPortal web interface to come up without much effort.  However, in the startup, one service fails to start properly: mgrep.  mgrep is supposed to start from init.d, but when we execute "service mgrep status," the response says the service is dead and the subsystem is locked.  We don't see anything showing up in logs about mgrep.  What would you advise that we do?  Thanks.

Stephen J. Granite, MS, MBA
Director of Database and Software Development
Center for Cardiovascular Bioinformatics and Modeling
Institute for Computational Medicine
The Johns Hopkins University
3400 North Charles Street
Hackerman Hall 312
Baltimore, MD 21218-2686
phone: 410-516-8849
fax: 410-516-5294



_______________________________________________
bioontology-support mailing list
bioontology-support at lists.stanford.edu<mailto:bioontology-support at lists.stanford.edu>
https://mailman.stanford.edu/mailman/listinfo/bioontology-support

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/bioontology-support/attachments/20130311/e4fc2d48/attachment.html>


More information about the bioontology-support mailing list