Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Pull Location Uploading not working

Jennifer Leigh Vendetti vendetti at stanford.edu
Tue Dec 6 11:51:41 PST 2016


Hi Vincent,

What is the pull location of the ontology?

Jennifer


> On Dec 6, 2016, at 10:27 AM, Vincent Emonet <vincent.emonet at lirmm.fr> wrote:
> 
> Hi,
> 
> On our local VA when we "add a submission" using a pull location the parsing of the ontology is hanging on:
> 
> "DEBUG -- : Pull location found, but no file in the upload file path. Retrying download."
> 
> https://github.com/sifrproject/ncbo_cron/blob/master/lib/ncbo_cron/ontology_submission_parser.rb#L168
> 
> After adding some logs to understand where it really comes from, I found that it was hanging when copying the file:
> 
> https://github.com/ncbo/ontologies_linked_data/blob/master/lib/ontologies_linked_data/models/ontology_submission.rb#L103:L109
> 
> Notice that the 2 logger.debug of copy_file_repository don't produce anything when run automatically
> 
> 
> 
> The mysterious thing, is that if I run the processing manually "/srv/ncbo/ncbo_cron/bin/ncbo_ontology_process -o MY_ONT".
> It's working without any problem.
> 
> I never touched this part of the code, and I experience this problem on the production and staging machines (and it was working before)
> 
> In the code I can see you already had some problems with it and added some logs to debug it (and did not remove them).
> 
> Do you have an idea where it could come from?
> 
> Thanks!
> 
> Vincent
> _______________________________________________
> bioontology-support mailing list
> bioontology-support at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/bioontology-support




More information about the bioontology-support mailing list