Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] EDAM update - same problem again - please help

Matus Kalas Matus.Kalas at uib.no
Tue Jan 16 18:36:36 PST 2018


Hi Jennifer and others,

Thank you so much for looking into this, and narrowing down the problem!

The current status with both EDAM and EDAM-BIOIMAGING is that when I'm 
logged out, everything is up to date, and when I'm logged in, the 
"Classes" browsing doesn't work, showing "We're sorry but something has 
gone wrong. We have been notified of this error."

A million thanks again for all your detailed answers & all best luck 
with finding and solving the problem,
Matus


On 2018-01-16 21:38, Jennifer Leigh Vendetti wrote:
> Hi Matus,
> 
> It would be helpful if you could send your comments to the support
> list so that my colleagues are able to remain in the loop on
> correspondences regarding BioPortal issues.
> 
> 
>> On Jan 15, 2018, at 3:15 PM, Matus Kalas <Matus.Kalas at uib.no> wrote:
>> 
>> When I open 
>> http://bioportal.bioontology.org/ontologies/EDAM/?p=classes without 
>> being loggen in, in a private browser window, it works fine.
>> 
>> When I'm logged in, 
>> http://bioportal.bioontology.org/ontologies/EDAM/?p=classes shows 
>> "We're sorry but something has gone wrong. We have been notified of 
>> this error.", and clicking "Classes" at 
>> http://bioportal.bioontology.org/ontologies/EDAM shows "Problem 
>> retrieving classes”.
> 
> 
> Are you still seeing a 500 error for EDAM classes page? I’m logged in
> and can’t reproduce this at the moment.
> 
> 
>> 
>> Another instance of the same kind of problem:
>> 
>> I uploaded a new version of 
>> http://bioportal.bioontology.org/ontologies/EDAM-BIOIMAGING about an 
>> hour ago, and it still shows it as not parsed at the summary page at 
>> http://bioportal.bioontology.org/ontologies/EDAM-BIOIMAGING, whether 
>> I'm looged in, or not logged in a private browser window.
> 
> 
> I was able to reproduce this behavior here (I’ve cleared BioPortal’s
> caches, so your ontology is accessible now). BioPortal has 3 distinct
> caching layers in the stack. Based on the information provided in your
> last two messages, we think we’ve narrowed the problem to the client
> side in-memory cache.
> 
> 
>> 
>> One more question, or rather two:
>> 
>> Is the CSV version for download generated by some internal BioPortal 
>> machinery, or is it using some available libraries?
> 
> 
> The CSV is generated internally, using Ruby’s standard CSV library:
> 
> https://github.com/ncbo/ontologies_linked_data/blob/master/lib/ontologies_linked_data/utils/ontology_csv_writer.rb
> 
> 
>> 
>> Related to that, if the summary page at 
>> http://bioportal.bioontology.org/ontologies/EDAM-BIOIMAGING doesn't 
>> show the new version as parsed, and thus doesn't provide it CSV, is 
>> there another URL I could use to download the newly generated CSV?
> 
> 
> No, not that I’m aware of.
> 
> 
>> 
>> This looks like quite a mess. Could you guys please somehow prioritize 
>> fixing these issues? It's causing us and our users some serious 
>> trouble.
> 
> 
> We take all problem reports seriously and care a great deal about
> providing end users with the best experience possible. Having said
> that, we’re a very small team supporting a relatively large user
> community. We’re doing the best we can with the resources we have and
> will continue to look into / address this issue as time permits.
> 
> Kind regards,
> Jennifer


More information about the bioontology-support mailing list