Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Feedback from yuki

Michael Dorf mdorf at stanford.edu
Fri Apr 12 13:54:52 PDT 2019


Hi Yuki,

We’ve deployed a fix to our production servers this morning that addressed the issue with viewing classes of your ontology. You should now be able to browse your ontology without issues:

http://stage.bioontology.org/ontologies/TXPO/?p=classes
http://stage.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http%3A%2F%2Fpurl.obolibrary.org%2Fobo%2FUBERON_0001062&jump_to_nav=true<http://stage.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http://purl.obolibrary.org/obo/UBERON_0001062&jump_to_nav=true>
http://bioportal.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http%3A%2F%2Fbioportal.bioontology.org%2Fontologies%2Ftxp%2FTXP_0001731<http://bioportal.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http://bioportal.bioontology.org/ontologies/txp/TXP_0001731>

I did not want to include the nitty gritty of the problem, but if you are curious, the two Github issues below provide more detail:

https://github.com/ncbo/bioportal_web_ui/issues/86
https://github.com/ncbo/ontologies_api/issues/53

Unfortunately, the problem with mappings still remains. The error is triggered by a mapping to a non-existent ontology (BILA) that is found in this class:

http://bioportal.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http%3A%2F%2Fpurl.obolibrary.org%2Fobo%2FUBERON_0001062<http://bioportal.bioontology.org/ontologies/TXPO/?p=classes&conceptid=http://purl.obolibrary.org/obo/UBERON_0001062>

We are looking into ways of addressing this issue, but it may not happen immediately.

Again, sorry for all the troubles with your ontology.

Michael




On Apr 11, 2019, at 8:59 PM, y-yamagata <y-yamagata at nibiohn.go.jp<mailto:y-yamagata at nibiohn.go.jp>> wrote:

H, Michael,

Thank you for your answer.
I tried to upload the English version as a new ontology using another acronym, TXP again.

As a result, I could confirm that the summary tab is visible, but the class tab is not visible.
https://bioportal.bioontology.org/ontologies/TXP?p=classes&conceptid=root

Therefore, next, enter the following URI, which can be seen before, in the address bar.
https://bioportal.bioontology.org/ontologies/TXP/?p=classes&conceptid=http://bioportal.bioontology.org/ontologies/txpo/TXP_0001731
As a result, all is-a trees including the above entities became visible.

Then, I confirmed that I could see on a few concepts appropriately and I entered the following URL.
https://bioportal.bioontology.org/ontologies/TXP?p=classes
As a result,  I could become to see the is-a hierarchy.
Furthermore, when I enter the following URI, which I could not see first,  I could view the tree.
https://bioportal.bioontology.org/ontologies/TXP?p=classes&conceptid=root

Note that if I log out and log in again, I will no longer be able to see the hierarchy even if I directly enter the following URI, so the above procedure is necessary each time.
https://bioportal.bioontology.org/ontologies/TXP?p=classes

It is very troublesome for users to perform this procedure after the release, but for now, it will be visible, so I try to think about other methods as well.

Thank you :)

Yuki



2019/04/12 3:50、Michael Dorf <mdorf at stanford.edu<mailto:mdorf at stanford.edu>> のメール:

Hi Yuki,

I was able to reproduce the problem (“We’re sorry…”), and I know the exact cause. Unfortunately, this isn’t a trivial one, and deleting your ontology and simply re-creating it isn’t going to address it. All I can say at this point is we are looking for possible solutions. I’ll keep you posted. Thank you so much for your patience!

Michael


On Apr 11, 2019, at 2:06 AM, y-yamagata <y-yamagata at nibiohn.go.jp<mailto:y-yamagata at nibiohn.go.jp>> wrote:

Dear John and Michael,

Thank you for the correspondence.
https://bioportal.bioontology.org/ontologies/TXPO?p=classes
The display always shows  ’Problem retrieving classes’ or ‘We’re sorry, but something has gone wrong...', regardless of how much the cache is cleared. I tried it on Chrome and Opera or FireFox.
It has not changed since several months ago.
If possible, can you delete the acronym TXPO and all data of TXPO from the BioPortal server and can I register the acronym TXPO again?

Best regards,
Yuki


2019/04/11 13:45、John Graybeal <jgraybeal at stanford.edu<mailto:jgraybeal at stanford.edu>> のメール:

Yuki,

Sorry for your remaining problems, thank you for providing those details.

When I tried your first example (classes of TXPO), the first time I tried it I got a failure indicator. But when I refreshed the browser the problem went away. Perhaps there is a timeout before this succeeds; you may find clearing your cache helps.

Re the second question, I only see 5 ontologies, not including BAO, go-plus, Uber Anatomy. Since the log looks OK, this suggests an issue with one of the other ontologies may be interfering with the display, or possibly something else has happened. I'll have to let Misha dig into that for you. (@Misha, the API endpoint seems consistent with the following list; but did not let me view info for the TXPO ontology as a whole.)

John

Genotype Ontology<https://bioportal.bioontology.org/mappings/show/TXPO?target=http://data.bioontology.org/ontologies/GENO&height=600&width=800> 23
Influenza Ontology<https://bioportal.bioontology.org/mappings/show/TXPO?target=http://data.bioontology.org/ontologies/FLU&height=600&width=800> 60
Ontology of Drug Neuropathy Adverse Events<https://bioportal.bioontology.org/mappings/show/TXPO?target=http://data.bioontology.org/ontologies/ODNAE&height=600&width=800>       70
Ontology of Genes and Genomes<https://bioportal.bioontology.org/mappings/show/TXPO?target=http://data.bioontology.org/ontologies/OGG&height=600&width=800>      1,246
Ontology of Host-Microbe Interactions<https://bioportal.bioontology.org/mappings/show/TXPO?target=http://data.bioontology.org/ontologies/OHMI&height=600&width=800>     33


On Apr 10, 2019, at 7:07 PM, y-yamagata <y-yamagata at nibiohn.go.jp<mailto:y-yamagata at nibiohn.go.jp>> wrote:


Hi Micahel,

Sorry, but there are still problems.

1. Class tab with the display.
I tried to clear my browser cache, log in again, and then I entered a URI https://bioportal.bioontology.org/ontologies/TXPO/?p=classes. However, my screen always shows ‘We ‘re sorry but something has gone wrong’
How is it displayed on your screen?
How can I display it correctly?
Curiously, it appears when I type in the URL of the term directly.
https://bioportal.bioontology.org<https://bioportal.bioontology.org/> /ontologies/TXPO/?p=classes&conceptid=http://bioportal.bioontology.org/ontologies/txpo/TXPO_0001731


2. Mapping
I reuse the term 'anatomical entity' in the UBERON ontology.
https://bioportal.bioontology.org<https://bioportal.bioontology.org/> /ontologies/TXPO/?p=classes&conceptid=http://purl.obolibrary.org/obo/UBERON_0001062<http://2fpurl.obolibrary.org%2fobo%2fuberon_0001062/>
The display shows:
Number of class mappings are 378.
Ontology mapping to Bio assay ontology, go-plus, Uber Anatomy Ontology etc.
However, in the mapping tab,  why is it not included UBERON, ?
Also, go-plus, Cell ontology, and so on, are not listed.

Best regards,
Yuki


2019/04/11 7:23、Michael Dorf <mdorf at stanford.edu<mailto:mdorf at stanford.edu>> のメール:

Hi Yuki,

Thank you for contacting us again. This is no bother at all. Feel free to reach out to us anytime you have an issue or question related to BioPortal.  As far as TXPO, please accept our apologies, our ontology processing engine had been disabled for the last few days due to an issue, which is why your new version hasn’t gotten processed.  It has now been re-enabled, and your ontology has been re-processed. It is now correctly displayed in BioPortal. Hopefully, fixing this issue has addressed all of the problems below. If this is not the case, please let us know.

https://bioportal.bioontology.org/ontologies/TXPO?p=classes

Thanks!

Michael


On Apr 9, 2019, at 7:13 PM, y-yamagata <y-yamagata at nibiohn.go.jp<mailto:y-yamagata at nibiohn.go.jp>> wrote:


Hi, Michel,

I apologize for bothering you over and over again.

I prepared an English version of the TXPO ontology, and my colleague uploaded it (2019/04/08).
However, there are problems.

1. Class tab
I tried to clear my browser (Chrome) cache, log in again, and see my page.
However, when I click the Classes tab, nothing is displayed except for the message "Problem retrieving classes.”

Next, to try out a class (TXPO_1171) that I could see before, I entered the following address into the chrome address bar:
https://bioportal.bioontology.org<https://bioportal.bioontology.org/> /ontologies/TXPO/?p=classes&conceptid=http://bioportal.bioontology.org/ontologies/txpo/TXPO_0001731
As a result, the Japanese mixed version, which is the old version, is displayed.
How can I see the latest version?

2. Other tabs
Also, the displays of other tabs are not the latest version.

I uploaded TXPO many times before, but it seems that the cache on the BioPortal server side is not cleared every time.
In the mapping tab, there are too few mapped numbers. It reflects the numbers from the old Japanese version. Many terms should be mapped to Gene ontology.


3. Summary tab
 I cannot download 'beta1 with our Japanese version' that was uploaded in 04/08/2019 as CVS, RDF/XML, or Diff.

The contents of TXPO are updated frequently. Therefore, we try to upload many times.
But I feel uncomfortable to post to the mailing list "the display is not the latest version" many times.
Can you suggest solutions to these problems so that we can always view the latest trees and mappings for TXPO?

Sincerely,
Yuki Yamagata, Ph.D.


<TXPO20190411.pptx>

========================
John Graybeal
Technical Program Manager
Center for Expanded Data Annotation and Retrieval /+/ NCBO BioPortal
Stanford Center for Biomedical Informatics Research
650-736-1632






-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/bioontology-support/attachments/20190412/10436b01/attachment-0001.html>


More information about the bioontology-support mailing list