Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Databiology: Default web portal credentials

Alex Mozejko alex.mozejko at databiology.com
Wed Jul 22 23:02:15 PDT 2020


Hi Alex,

Apologies for taking so long to get back to you on this.

Thank you very much to the “firstboot” tip, that worked a treat.

A couple of weeks ago I created a request at https://license.ontoportal.org/licenses for appliance id d8d04b7b-577b-4d09-b40a-82ccc0a12b99<https://license.ontoportal.org/licenses%20for%20appliance%20id%20d8d04b7b-577b-4d09-b40a-82ccc0a12b99>. Can you please double check that this hasn’t been lost? I’m happy to provide additional information if required.

Also we’re having issues loading new Ontologies, we can use the portal to upload a file and it appears in the list however when clicking into the Ontology, the summary tab shows:

Metrics
We have not yet calculated metrics for ONTOLOGY

Visits
We are still collecting data for ONTOLOGY

And the “classes” tab reports:

“Problem retrieving classes”
Does any of this sound familiar? Or can you suggest some logs to read which might point us in a right direction to solve?

Apologies again for taking so long to respond.

Thanks,
Alex.

From: Alex Skrenchuk <alex.skrenchuk at stanford.edu>
Sent: Friday, 3 July 2020 5:42 AM
To: Alex Mozejko <alex.mozejko at databiology.com>; support at bioontology.org
Subject: Re: [bioontology-support] Databiology: Default web portal credentials

HI Alex,

We have not yet experimented with importing OVA to AWS because we are counting that the majority of users will deploy OntoPortal from the AWS marketplace.   We were recently been made aware that version 3.0.1 of the appliance sometimes doesn’t initialize properly in AWS during the first boot which could be usually resolved with a second reboot.

During the very first boot of the appliance we have a firstboot script that resets API keys for the Web UI and Admin user.  If it detects that appliance is running in AWS then it will also resets Admin password to match the instance-id of your EC2 instance.

First I would try to use the EC2 instance-id for admin password and if that doesn’t work then you could try to force re-run of the firstboot script.

ssh to instance as centos user and:

sudo touch /srv/ontoportal/firstboot
sudo chown ontoportal /srv/ontoportal/firstboot
sudo reboot


-Alex


From: bioontology-support <bioontology-support-bounces at lists.stanford.edu<mailto:bioontology-support-bounces at lists.stanford.edu>> on behalf of Alex Mozejko <alex.mozejko at databiology.com<mailto:alex.mozejko at databiology.com>>
Date: Thursday, July 2, 2020 at 8:00 AM
To: "support at bioontology.org<mailto:support at bioontology.org>" <support at bioontology.org<mailto:support at bioontology.org>>
Subject: [bioontology-support] Databiology: Default web portal credentials

Hello,

We have recently deployed the Bioportal appliance to one of our AWS environments but can’t seem to login using the credentials:

Username: admin
Password: changemeNOW

Whenever I try I get the error:

“Errors On Form.
Invalid account name/password combination”

The default ssh user credentials worked and I can confirm ssh access.

I can also confirm that creating a new user and uploading an ontology works, so good news there 😊

The process I followed to deploy this appliance is as follows:


  1.  Download OVA image from https://bioportal.bioontology.org/virtual_appliance
  2.  Copy OVA to s3 bucket
  3.  Use aws cli to convert image to AMI as detailed here<https://docs.aws.amazon.com/vm-import/latest/userguide/vmimport-image-import.html>
  4.  Launched virtual machine using the converted AMI
  5.  Navigate to portal
  6.  Try to login as admin
  7.  Get error

Can you please confirm that the credentials I’m trying to use are correct? And is there a way to reset the ‘admin’ user’s password?

Thanks,
Alex.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/bioontology-support/attachments/20200723/cb145a14/attachment-0001.html>


More information about the bioontology-support mailing list