Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] Question about processing UMLS ontology

Michael Vladimir Dorf mdorf at stanford.edu
Tue Mar 10 16:38:58 PDT 2020


Hi Jahoon,

As much as I’d love to help, this question falls far beyond the scope of our support coverage. Without going further into the details of your installation, which essentially requires replicating your own environment, it’s difficult for us to ascertain what causes this error. One thing for sure is we have not seen the “Incomplete response received from application” on either our Staging or Production servers.

When we load UMLS ontologies into BioPortal, we follow our own internal process, which does not involve uploading each TTL file individually. As we had previously pointed out, the process of using a TTL file (instead of OWL or OBO) has not been tested or verified on our end. Since TTL is RDF, we just “assume” the OWL API parser should be able to handle it, but again, this has not been confirmed on our end. We are only a team of two who are in charge of the development, maintenance, and support of the entire BioPortal infrastructure, so we, unfortunately, must be highly selective with the tasks we focus on.

Sincerely,


----------------------------------------------------
Michael Dorf
Chief Software Architect
The National Center for Biomedical Ontology
Stanford Biomedical Informatics Research
mdorf at stanford.edu<mailto:mdorf at stanford.edu>
O: 650-723-0357
M: 650-995-4374
----------------------------------------------------

On Mar 10, 2020, at 2:21 PM, Koo, Jahoon <JAHOON.KOO at UCDENVER.EDU<mailto:JAHOON.KOO at UCDENVER.EDU>> wrote:

Hi BioPortal,

This is Jahoon, a student worker from Health Data Compass.

I am trying to upload ICD9CM ontology to my virtual appliance.
I have used UMLS2RDF script to create a ttl file of ICD9CM ontology and uploaded the ttl file through the browser UI of my virtual appliance.
However, I got “Incomplete response received from application” error on the browser.
I have checked log files, but I believe the submission itself has not made it through because there was no submission directory for ICD9CM in /srv/ncbo/repository directory.
In my appliance.log file from /srv/ncbo/ontologies_api/shared/log directory, I was able to check the error log below.

<image003.png>

Can you please help me fixing this error?

Respectfully,
Jahoon
_______________________________________________
bioontology-support mailing list
bioontology-support at lists.stanford.edu<mailto:bioontology-support at lists.stanford.edu>
https://mailman.stanford.edu/mailman/listinfo/bioontology-support

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/bioontology-support/attachments/20200310/a5a03f31/attachment-0001.html>


More information about the bioontology-support mailing list