Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[bioontology-support] [BioPortal] Feedback from mriyayi

John Graybeal jgraybeal at
Thu Mar 4 12:56:18 PST 2021


I'm not sure if it was the passage of time (sorry for that), or you made some changes since sending this message. It appears PANET is now working correctly, as I can drill all the way down the classes tree.

Please respond to the list if there are still issues you are seeing.


On Feb 11, 2021, at 11:28 PM, DANIEL IYAYI <mriyayi at<mailto:mriyayi at>> wrote:

Thanks John,

I have made some alterations, and uploaded a new version.

I have yet to create the expands namespace but the plan is to use purl or w3 to do this (perhaps this is the root cause of the problem)

Initially, I was able to see the classes in Bioportal when I use google chrome (see below) but when I cleared the cache it disappeared. It was not visible when I use internet explorer or microsoft edge as a browser.

My collegues cannot see the classes in any browser.

Kind regards

From: John Graybeal <jgraybeal at<mailto:jgraybeal at>>
Sent: 09 February 2021 00:29
To: support at<mailto:support at> <support at<mailto:support at>>
Cc: mriyayi at<mailto:mriyayi at> <mriyayi at<mailto:mriyayi at>>
Subject: Re: [bioontology-support] [BioPortal] Feedback from mriyayi

Hello Dan,

i'm responding here to both your contacts from today, they each had useful information. The ontology Classes tab is consistently showing an error for me as of mid-day Pacific Time today.

I have a theory about why it seemed to change "later", and a theory about what's wrong, but I'm not 100% confident in either. Unfortunately I'm not an ontology expert and we are a very resource-limited, but this will hopefully provide some insight about what has happened and what you might try.

** What's failing **

I'll start with the reason BioPortal is failing to display the ontology classes: it is unable to find the root class for your ontology tree. So it displays one or another error.

If I open your ontology in Protege, I see that there is an apparent root class, OBI_0000070. But it seems Protege is not recognizing your entities below that—it is showing the full string for them within angle brackets < >.

** Ontology diagnosis **

The ExPaNDS:' notation would expand into a full IRI if it could, but ExPaNDS is not included in the ontology prefixes. So these may not be expanding into valid IRIs. (Protege often does its best to parse cases like this anyway, so the absence of errors does not mean the ontology is well-formed.)

In addition, there are unescaped spaces in your IRI terms,

I verified some of this by plugging your ontology into, which indicated in the first parser that it tried (RDF) that the expansion in line 51 did not result in an appropriate IRI. Removing the space seemed to fix that issue.  I didn't try removing all the spaces for lack of time.  You might want

** Why you didn't see this Friday **

I am guessing what changed 'after Friday' is that when you first made changes to your ontology on Friday, they had not been fully reflected in the Classes page display, which can be cached internally in BioPortal for some hours, or even in your browser cache. So you could have been seeing working data from a previous submission, which eventually went away after the cache expired in BioPortal and/or in your browser. I apologize that these delays sometimes happen, I know it is annoyingly confusing.

** What you can try **

Of course you can try eliminating all the spaces and providing the prefix expansion for that ExPaNDS notation, that might take care of it. Getting the file to pass the validator is probably an important step.

Or, if you go back to an ontology you know worked, you could resubmit it and see if (after an appropriate period of time, I'd say that's 2 hours followed by clearing your browser cache) BioPortal begins showing classes again.

If you are unable to make the ontology work after addressing those issues, resubmit your question with the current symptoms and we'll see if there's anything we can add.


<Screen Shot 2021-02-08 at 4.04.46 PM.png>

<Screen Shot 2021-02-08 at 4.05.17 PM.png>

On Feb 8, 2021, at 10:34 AM, support at<mailto:support at> wrote:

Name: mriyayi
Email: mriyayi at<mailto:mriyayi at>

The Classes tab is intermittently showing 'Problem retrieving classes'. The OWL file uploaded seems to be fine.
Please can you investigate and let us know.
Kind regards

Subject: [bioontology-support] Error Message -
Date: February 8, 2021 at 10:38:52 AM PST
To: "support at<mailto:support at>" <support at<mailto:support at>>, "Collins, Steve (DLSLtd,RAL,SCI)" <steve.collins at<mailto:steve.collins at>>


I have uploaded an OWL file to

It is intermittently showing an error 'problem retrieving classes'.


It worked last Friday and nothing has changed since then. Please can you investigate

Kind regards

bioontology-support mailing list
bioontology-support at<mailto:bioontology-support at>

John Graybeal
Technical Program Manager
Center for Expanded Data Annotation and Retrieval /+/ NCBO BioPortal
Stanford Center for Biomedical Informatics Research
650-736-1632  | ORCID  0000-0001-6875-5360

John Graybeal
Technical Program Manager
Center for Expanded Data Annotation and Retrieval /+/ NCBO BioPortal
Stanford Center for Biomedical Informatics Research
650-736-1632  | ORCID  0000-0001-6875-5360

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bioontology-support mailing list