<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>I am trying to use the Bioportal rest service to search for OBO term ids without success. For example searching for GO:0000001 returns no match.<o:p></o:p></p><p class=MsoNormal>The rest call is: <o:p></o:p></p><p class=MsoNormal><a href="http://rest.bioontology.org/bioportal/search/?query=GO%3A0000001&apikey=24e050ca-54e0-11e0-9d7b-005056aa3316">http://rest.bioontology.org/bioportal/search/?query=GO%3A0000001&apikey=24e050ca-54e0-11e0-9d7b-005056aa3316</a><o:p></o:p></p><p class=MsoNormal>I get similar results using the BioPortal search UI.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>The reason I believe the search is failing is because the default Lucene analyzer being used by BioPortal is treating the : as a word separator. The solution we have had to use in LexEVS’s lucene implementation is to use a custom analyzer that doesn’t treat the : as a word separator. <o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Since the colon is an integral part of the term ID in all OBO ontologies, I believe we should have a way to search for them in BioPortal’s search implementation.<o:p></o:p></p></div></body></html>