<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>Hi Dan, </div><div><br></div><div>This appears to be working now. The proper format of the web service call is:</div><div><a href="http://rest.bioontology.org/bioportal/search/?query=Alignment&ontologyids=1498&isexactmatch=false&subtreerootconceptid=http%3A%2F%2Fedamontology.org%2Ftopic_0003&apikey=YourAPIKey">http://rest.bioontology.org/bioportal/search/?query=Alignment&ontologyids=1498&isexactmatch=false&subtreerootconceptid=http%3A%2F%2Fedamontology.org%2Ftopic_0003&apikey=YourAPIKey</a></div><div>This call returns 8 results. </div><div><br></div><div>Note that the parameter "isexactmatch" is set to false to match terms that <i>contain</i> the string 'alignment' versus looking for the exact string 'alignment' within the 'topic' subtree. Also, the value for the parameter "subtreerootconceptid" needs to be uri-encoded as described in the wiki documentation for this parameter.</div><div><br></div><div>Best, </div><div>Trish </div><div><br></div><div><br></div><br><div><div>On Nov 21, 2012, at 2:11 PM, Trish Whetzel wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div>Hi Dan, <br><br>As best I can tell, there appears to be a bug when including the "subtreerootconceptid" parameter in that the searchBean information is not returned, i.e. the actual search results. When changing the param "isexactmatch" from true to false the value of "numHitsTotal" changes from 3 to 212 but with no actual results returned and I've tried this call with previous examples that now also do not return the actual search results. <br><br>I'll submit a bug report on this issue. To help prioritize, can you provide a few details on the effect of this issue on your project, e.g. can not move forward with project or can wait a few weeks for this to be resolved. <br><br>Trish <br><br><br>On Nov 21, 2012, at 1:23 PM, Dan Bolser wrote:<br><br><blockquote type="cite">Hi,<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">I'm trying to do a REST search with subtreerootconceptid [1] because<br></blockquote><blockquote type="cite">my search term 'Alignment' matches several branches of the EDAM<br></blockquote><blockquote type="cite">ontology. For example:<br></blockquote><blockquote type="cite"><a href="http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment">http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment</a><br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Returns the following three concepts:<br></blockquote><blockquote type="cite">* EDAM_data:1916<br></blockquote><blockquote type="cite">* EDAM_topic:0083<br></blockquote><blockquote type="cite">* EDAM_operation:2928<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">In this particular search, I only want to return concepts in the<br></blockquote><blockquote type="cite">'topic' branch of the EDAM ontology, so I'm trying the following (and<br></blockquote><blockquote type="cite">various permutations thereof):<br></blockquote><blockquote type="cite"><a href="http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment&subtreerootconceptid=EDAM_topic%3A0003">http://rest.bioontology.org/bioportal/search?apikey=sekret&ontologyids=1498&isexactmatch=true&query=Alignment&subtreerootconceptid=EDAM_topic%3A0003</a><br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Nothing I've tried seems to work, returning zero hits instead of the<br></blockquote><blockquote type="cite">previous three. This seems to be the right way to specify the 'topic'<br></blockquote><blockquote type="cite">branch, being the subtree of the topic node:<br></blockquote><blockquote type="cite"><a href="http://bioportal.bioontology.org/ontologies/47814/?p=terms&conceptid=EDAM_topic%3A0003">http://bioportal.bioontology.org/ontologies/47814/?p=terms&conceptid=EDAM_topic%3A0003</a><br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Am I doing something wrong?<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Many thanks for any suggestions,<br></blockquote><blockquote type="cite">Dan.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">[1] <a href="http://www.bioontology.org/wiki/index.php/BioPortal_REST_services#Search_BioPortal">http://www.bioontology.org/wiki/index.php/BioPortal_REST_services#Search_BioPortal</a><br></blockquote><blockquote type="cite">_______________________________________________<br></blockquote><blockquote type="cite">bioontology-support mailing list<br></blockquote><blockquote type="cite"><a href="mailto:bioontology-support@lists.stanford.edu">bioontology-support@lists.stanford.edu</a><br></blockquote><blockquote type="cite"><a href="https://mailman.stanford.edu/mailman/listinfo/bioontology-support">https://mailman.stanford.edu/mailman/listinfo/bioontology-support</a><br></blockquote><br>_______________________________________________<br>bioontology-support mailing list<br><a href="mailto:bioontology-support@lists.stanford.edu">bioontology-support@lists.stanford.edu</a><br>https://mailman.stanford.edu/mailman/listinfo/bioontology-support<br></div></blockquote></div><br></body></html>