<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=utf-8">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <p>Hi,</p>
    <p>I am experiencing some troubles with the consistency of the data
      model</p>
    <p>I am trying to get a Slice (acronym is lovinra)</p>
    <ul>
      <li>This slice exists:</li>
    </ul>
    <p>You can see it here <a class="moz-txt-link-freetext" href="http://data.stageportal.lirmm.fr/slices">http://data.stageportal.lirmm.fr/slices</a></p>
    <p>And when I run the following to get all the slices: <br>
    </p>
    <p><font face="Courier New, Courier, monospace">slices =
LinkedData::Models::Slice.where.include(LinkedData::Models::Slice.attributes(:all)).all</font></p>
    <p>One of the slices returned is lovinra:<br>
    </p>
    <p><font face="Courier New, Courier, monospace">#<LinkedData::Models::Slice:0x007fe666f03670<br>
          @acronym="lovinra",<br>
          @aggregates=nil,<br>
          @created=#<DateTime: 2016-03-23T14:41:16+01:00
        ((2457471j,49276s,0n),+3600s,2299161j)>,<br>
          @description=</font><br>
      <br>
    </p>
    <ul>
      <li>But when retrieving it using "find" <br>
      </li>
    </ul>
    <p><font face="Courier New, Courier, monospace">slice =
LinkedData::Models::Slice.find("lovinra").include(LinkedData::Models::Slice.attributes(:all)).first</font></p>
    <p>It returns nil.</p>
    <p>If I try to find another slice acronym (cismef for example) I get
      the slice object.<br>
    </p>
    <br>
    <br>
    Note that I run those command using bin/ncbo_cron --console<br>
    With security disabled in CRON config.<br>
    <br>
    Do you have an idea where this come from?<br>
    <br>
    <br>
    Thanks!<br>
    <br>
    Vincent<br>
  </body>
</html>