<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">
Hello Dan,
<div class=""><br class="">
</div>
<div class="">
<div><br class="">
<blockquote type="cite" class="">
<div class="">On Apr 28, 2019, at 7:14 AM, Daniel Hier <<a href="mailto:dbhier@dbhier.com" class="">dbhier@dbhier.com</a>> wrote:</div>
<br class="Apple-interchange-newline">
<div class="">
<div dir="ltr" class="">
<div class="">Thank you for helping me with my ontology NEO (neurological examination ontology).  I have decided to rebuild it from scratch in PROTEGE and my partial version with 400 classes and it will now load properly.  I will finish it with 650 classes. 
 I particularly like the download feature of CSV file--that is a very nice feature that I will use when I post-process my file.</div>
<div class=""><br class="">
</div>
<div class="">Thanks again for your help.  There must have been subtle errors in my original ontology.  I am about 60% done rebuilding it.</div>
</div>
</div>
</blockquote>
<div><br class="">
</div>
<div><br class="">
</div>
<div>OK - thanks for letting us know that you’ve made additional uploads. </div>
<div><br class="">
</div>
<div>Nonetheless, I did want to track down why your previous submissions were failing. The problem occurred fairly deep in our stack in some code where we use a 3rd party library to load / parse ontologies. Normally this library produces helpful error messages,
 but in this particular case, we weren’t getting any indication of failure, so it took some digging around and testing before i was able to isolate the issue.</div>
<div><br class="">
</div>
<div>It turns out there’s a syntax error on line 1033 of your ontology (shown in bold below):</div>
<div><br class="">
</div>
<div><!-- <a href="http://webprotege.stanford.edu/R95MZmrikwqzrjl7N1cShdN" class="">
http://webprotege.stanford.edu/R95MZmrikwqzrjl7N1cShdN</a> --></div>
<div><br class="">
</div>
<div><owl:Class rdf:about="<a href="http://webprotege.stanford.edu/R95MZmrikwqzrjl7N1cShdN" class="">http://webprotege.stanford.edu/R95MZmrikwqzrjl7N1cShdN</a>"></div>
<div>  <rdfs:subClassOf rdf:resource="<a href="http://webprotege.stanford.edu/RCAfDthAKPwhOppuDOBzZo2" class="">http://webprotege.stanford.edu/RCAfDthAKPwhOppuDOBzZo2</a>"/></div>
<div>  <webprotege:R8JlHtLpsj8hW18voM8qfVy>&lt;apraxic gait&gt;&lt;Bruns apraxia&gt;&lt;magnetic gait&gt;&lt;frontal gait&gt;|</webprotege:R8JlHtLpsj8hW18voM8qfVy></div>
<div>  <webprotege:R9erWLcZm8MU17huk4CFMwy>|30767006|</webprotege:R9erWLcZm8MU17huk4CFMwy></div>
<div>  <BbHRvdgdu3Y4vbyVxXTwfu:UMLS>C1510417</BbHRvdgdu3Y4vbyVxXTwfu:UMLS></div>
<div>  <rdfs:label>gait apraxia</rdfs:label></div>
<div>  <b class=""><skos:definition rdf:resource="apraxia for walking, accompanied by inability to make skilled walking movements with the legs.gait apraxia; unexplained by weakness, sensory loss, or incoordination (n.d.) Farlex Partner Medical Dictionary.
 (2012). [Retrieved April 21 2016 from <a href="http://medical-dictionary.thefreedictionary.com/gait+apraxia" class="">
http://medical-dictionary.thefreedictionary.com/gait+apraxia</a>]"/></b></div>
<div></owl:Class></div>
<div><br class="">
</div>
<div>… where a skos:definition has an opening tag, but no closing tag. I added an end tag, i.e.:</div>
<div><br class="">
</div>
<div> <skos:definition>apraxia for walking, accompanied by inability to make skilled walking movements with the legs.gait apraxia; unexplained by weakness, sensory loss, or incoordination (n.d.) Farlex Partner Medical Dictionary. (2012). [Retrieved April 21
 2016 from <a href="http://medical-dictionary.thefreedictionary.com/gait+apraxia" class="">
http://medical-dictionary.thefreedictionary.com/gait+apraxia</a>]</skos:definition></div>
<div><br class="">
</div>
<div>... and tested uploading this fixed version of your ontology in our staging environment, and it succeeded.</div>
<div><br class="">
</div>
<div>I’m wondering - did you hand edit your ontology file before you submitted it to BioPortal? Or, did you simply upload the file that you exported from WebProtege? If it’s the latter, I recommend notifying the Protege team that your ontology was exported
 without an end tag for that particular skos definition.</div>
<div><br class="">
</div>
<div>Kind regards,</div>
<div>Jennifer</div>
<div><br class="">
</div>
</div>
</div>
</body>
</html>