Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[farmshare-discuss] Issue Logging In with Putty on Windows

Chris Young cvyoung at stanford.edu
Sat Sep 29 13:07:07 PDT 2012


Thanks guys, enabling GSSAPI seems to have fixed both the credentials  
problem and the Xwindows forwarding probem!

My previous settings worked last year before the system was updated --  
haven't tried logging in on this computer since then.

Chris


On Sep 29, 2012, at 12:57 PM, Adam Seishas wrote:

> Try enabling GSSAPI credentials delegation for the session in PuTTY:
>
> https://www.stanford.edu/group/farmshare/cgi-bin/wiki/index.php/Advanced_Connection_Options 
> #PuTTY
>
> I think Victor is right: you’re not able to access your home  
> directory after login because you don’t have an AFS token, which  
> causes the file locking issue.
>
>> Adam Seishas
> IT Service Desk
> Stanford University
> aseishas at stanford.edu
>
>
>
> On Sep 29, 2012, at 12:48 PM, Chris Young <cvyoung at stanford.edu>  
> wrote:
>
>> Hi Victor,
>>
>> I was connecting to the general corn.stanford.edu.  I just tried  
>> corn13 and corn15 and got the same thing with the .Xauthority file.
>>
>> I have the Stanford kerberos program where I put my password in  
>> once when I first log in to my computer.
>>
>> Running "kinit -f" prints nothing to the screen after I put in my  
>> password.
>>
>> I'm running the XWin Server that come with Cygwin-X.  I know that's  
>> not the problem because I can log into another unix cluster I use  
>> for work (they're running Linux on Intel Xeon cores, not sure if  
>> that matters) and I can get x windows forwarded and appearing on my  
>> local desktop.
>>
>> Thanks for getting back so quickly,
>> Chris
>>
>>
>> On Sep 29, 2012, at 12:37 PM, Victor Chavez wrote:
>>
>>> On Sep 29, 2012, at 12:32 PM, Chris Young <cvyoung at stanford.edu>  
>>> wrote:
>>>> I was wondering if someone could shed some light on an error I'm  
>>>> getting logging in to corn on a PC using Putty.  (Everything  
>>>> works fine on my mac using X11 and the -X flag for ssh.)
>>>>
>>>> I have X11 forwarding enabled.  When I first log in it hangs for  
>>>> several seconds and I get a message:
>>>> /usr/bin/xauth: timeout in locking authority file /afs/ir/users/c/ 
>>>> v/cvyoung/.Xauthority
>>>>
>>>> I can do simple things like change directories, but all the file  
>>>> permissions in my home directory have "???????" listed until I do  
>>>> a "kinit; aklog" and type in my password.
>>>>
>>>> I also can't do anything requiring X11 windows.  Trying to run  
>>>> "xclock" gives:
>>>> "PuTTY X11 proxy: wrong authorisation protocol attempted"
>>>> "Error: Can't open display: localhost:14.0"
>>>>
>>>> I'm assuming it's something in my Putty settings for SSH.   
>>>> Anybody run across something like this before?
>>>
>>>
>>> Are you connecting to 'corn.stanford.edu' or a specific corn?  If  
>>> you try logging into another corn, do you get different behavior?
>>>
>>> Are you using password auth or kerberos?  When you login, can you  
>>> run 'kinit -f' and paste the results?
>>>
>>> And just checking: do you have an X Server on your Windows system  
>>> (e.g. Xming)?
>>>
>>> -- 
>>> Victor Chavez, 650.736.8350
>>> Sr. SysAdmin, Stanford IT Services
>>>
>>> _______________________________________________
>>> farmshare-discuss mailing list
>>> farmshare-discuss at lists.stanford.edu
>>> https://mailman.stanford.edu/mailman/listinfo/farmshare-discuss
>>
>> _______________________________________________
>> farmshare-discuss mailing list
>> farmshare-discuss at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/farmshare-discuss
>
> _______________________________________________
> farmshare-discuss mailing list
> farmshare-discuss at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/farmshare-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/farmshare-discuss/attachments/20120929/1eaa820b/attachment.html>


More information about the farmshare-discuss mailing list