Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[farmshare-discuss] Git Clone fatal error (sha1 file, timeout)

Charles E Yates ceyates at stanford.edu
Thu Sep 15 18:06:56 PDT 2016


Clone to /tmp then copy to where you want it.  Seems git clone and afs don't play well together.
________________________________
From: farmshare-discuss <farmshare-discuss-bounces at lists.stanford.edu> on behalf of Andreas Santucci <santucci.andreas at gmail.com>
Sent: Thursday, September 15, 2016 1:53:44 PM
To: farmshare-discuss at lists.stanford.edu
Subject: [farmshare-discuss] Git Clone fatal error (sha1 file, timeout)

Dear Farmshare Mailing List,

I am quite consistently encountering a connection time-out when trying to clone git repositories on Corn, regardless whether I attempt to clone via SSH or HTTPS.

Using HTTPS:
santucci at corn12:~$ git clone https://github.com/CME211/cme211-asantucci.git
Cloning into 'cme211-asantucci'...
Username for 'https://github.com': asantucci
Password for 'https://asantucci@github.com':
remote: Counting objects: 52, done.
remote: Compressing objects: 100% (24/24), done.
fatal: error when closing sha1 file: Connection timed out

Using SSH:
santucci at corn12:~$ git clone git at github.com:CME211/cme211-asantucci.git
Cloning into 'cme211-asantucci'...
remote: Counting objects: 52, done.
remote: Compressing objects: 100% (24/24), done.
remote: Total 52 (delta 9), reused 0 (delta 0), pack-reused 24
Receiving objects: 100% (52/52), 10.18 MiB | 1.31 MiB/s, done.
Resolving deltas: 100% (15/15), done.
Checking connectivity... done.
error: unable to create file hw1/alignments3.txt (Connection timed out)
... (More connection time-outs here) ...
fatal: unable to checkout working tree
warning: unable to unlink .git/index.lock: Connection timed out
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry the checkout with 'git checkout -f HEAD'

Attempts to follow the instructions above (retrying the checkout) leads only to more time-outs.

Last Ditch Effort: Adding SSH Keys to GitHub Account:
I've also tried to follow some of the instructions listed here on GitHub<https://help.github.com/categories/ssh/> pertaining to adding SSH Keys or GPG Keys manually to a GitHub account.

Question:
What is the correct way to remedy this error? Executing the same commands from a local machine causes no problems. I apologize that the repository listed above is private. For a public repo which also causes the same error, try:

git clone https://github.com/HazyResearch/snorkel.git

Thank you for your time and attention, please let me know if I can add any clarifying details.

Andreas Santucci







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/farmshare-discuss/attachments/20160916/867be6a4/attachment.html>


More information about the farmshare-discuss mailing list