Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[farmshare-discuss] Python3 (Outdated) Version

Andreas Santucci santucci.andreas at gmail.com
Tue Sep 20 22:09:57 PDT 2016


Currently, the python3 command on Corn launches python 3.3.5 (for me).

santucci at corn28:~$ python3
Python 3.3.5 (default, Sep 21 2014, 22:14:07)
[GCC 4.8.1] on linux
Type "help", "copyright", "credits" or "license" for more information.

There is a newer version installed as well, 3.4.3, but it must be called
manually via python3.4
santucci at corn28:~$ python3.4
Python 3.4.3 (default, Oct 14 2015, 20:28:29)
[GCC 4.8.4] on linux
Type "help", "copyright", "credits" or "license" for more information.

Is there a way we can request that the outdated version be removed from the
python3 alias?

System Information:
santucci at corn28:~$ echo $SHELL
/bin/bash

santucci at corn28:~$ echo $PATH
/farmshare/software/free/oge/2011.11p1/bin/linux-x64:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

(As a secondary issue, is it possible this behavior may vary from corn
machine to corn-machine? E.g., if one is using Corn23 vs Corn28? If this is
might be the case, what are the guarantees of homogeneity among Corn
servers?)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/farmshare-discuss/attachments/20160921/c58ffcd9/attachment.html>


More information about the farmshare-discuss mailing list