Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] In-band Controller in Mininet

Gregory Gee gee.developer at gmail.com
Mon Dec 30 12:13:36 PST 2013


   I even just tried creating a netns called s1 and moving just the OVS 
interfaces into it, not the full ovsdb/... , but then packets stopped 
forwarding.

   I'll have to play with it a bit more, but not sure if I will succeed.

Greg

On 30/12/2013 2:58 PM, Gregory Gee wrote:
>
>   Yah, I'm still learning what can be done with the linux netns 
> namespaces.  I believe you are correct it that the correct workaround 
> seems to be running multiple instances of ovsdb/ovs-vswitchd, each in 
> it's own namespace.  I'm not sure how well that could scale though.
>
> Greg
>
> On 30/12/2013 3:18 AM, Volkan YAZICI wrote:
>> Thanks for the reply Gregory. I read the thread you pointed and its 
>> references as well, but they did not really help. It might be due to 
>> my lack of information on the subject too. Further, I do not have a 
>> clear perception about what "inNamespace" flag turns on and off. Are 
>> we supposed spawn multiple ovsdb/ovs-vswitchd processes? Or can 
>> in-band control plane be implemented via namespace tricks? Any helps 
>> on the subject will be really appreciated.
>>
>>
>> On Mon, Dec 30, 2013 at 4:27 AM, Gregory Gee <gee.developer at gmail.com 
>> <mailto:gee.developer at gmail.com>> wrote:
>>
>>
>>       Hmm, interesting.  I wonder if the packets are jumping from s1
>>     to s2 through the root network namespace instead of using the
>>     link? Looks like a topic Bob discussed a while back when I did
>>     through the OVS mailing list.  Looks like there is a workaround,
>>     but I'm not sure how well it would scale if you want to test it
>>     with large networks.
>>
>>     https://mailman.stanford.edu/pipermail/mininet-discuss/2013-March/001827.html
>>
>>       Would be interested to here now/if people solved this
>>
>>     Greg
>>
>>
>>     On 27/12/2013 7:36 PM, Ahmad Soltani wrote:
>>
>>         on the subject of in-band controller in mininet,
>>         Volkan, I checked it with wireshark, You're right.
>>         I couldn't observe any OpenFlow activities anywhere on the
>>         network except in the switch that was directly connected to
>>         the controller (and specifically the interface that is
>>         connected to the host which runs the controller)
>>         The debug messages on the controller however clearly show
>>         that the controller connects to all switches.
>>         How could the controller connect to a switch without
>>         handshaking (OFP echo req/rep)?
>>
>>         _______________________________________________
>>         mininet-discuss mailing list
>>         mininet-discuss at lists.stanford.edu
>>         <mailto:mininet-discuss at lists.stanford.edu>
>>         https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>>
>>
>>     _______________________________________________
>>     mininet-discuss mailing list
>>     mininet-discuss at lists.stanford.edu
>>     <mailto:mininet-discuss at lists.stanford.edu>
>>     https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>>
>>
>>
>>
>> _______________________________________________
>> mininet-discuss mailing list
>> mininet-discuss at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20131230/1c850dab/attachment.html>


More information about the mininet-discuss mailing list