Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] Mininet + OVS + VlAN

Gregory Gee gee.developer at gmail.com
Fri Apr 25 05:08:42 PDT 2014


In not totally sure, but I assume the controller is overriding your
setting. Anyway, isn't seeing the VLAN something you want to do via the
controller?

Greg
 On Apr 24, 2014 10:55 AM, "Arun Sharma" <arunain at gmail.com> wrote:

> Hello,
>
> I was trying to configure VLAN on OVS switch on mininet environment. Even
> though i set tag on port entry but still nodes on different VLAN tag pings
> each other.
> Here is how what i have configured.
>
> mininet> net
> c0
> s1 lo:  s1-eth1:h1-eth0
> s2 lo:  s2-eth1:vh1-eth0 s2-eth2:vh2-eth0
> h1 h1-eth0:s1-eth1
> vh1 vh1-eth0:s2-eth1
> vh2 vh2-eth0:s2-eth2
>
> mininet at mininet-dev:~$ sudo ovs-vsctl set port s2-eth2 tag=11
> mininet at mininet-dev:~$ sudo ovs-vsctl set port s2-eth1 tag=12
>
> mininet> vh1 ping vh2
> PING 10.1.0.2 (10.1.0.2) 56(84) bytes of data.
> 64 bytes from 10.1.0.2: icmp_req=1 ttl=64 time=123 ms
>
> <<<< It was expected that above ping should fail but ping works >>>>>
>
>
> Is there anything i am missing? Is there any proper document/link which i
> can refer to configure VLAN on mininet.
>
>
> Regards, Arun
>
>
>
>
>
> _______________________________________________
> mininet-discuss mailing list
> mininet-discuss at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20140425/8ff95635/attachment-0001.html>


More information about the mininet-discuss mailing list