Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] Cannot allocate memory error

江卓 juejiang91 at gmail.com
Sat Mar 14 08:01:49 PDT 2015


Hi,all.
I came across a "Cannot allocate memory error" when I tried to use CLI(net)
in my code.To make the scenario simpler, I run "sudo mn" in my ubuntu 14.04
system, the same kind of error occured. It seems quite strange since "sudo
mn " runs successfully when I first installed mininet. The full error
information is as follow.
It seems to me the reason for this is python's memory leak. I can see the
system's memory increases rapidly with "free -m". Any suggestions to fix
this?
Thanks in advance.

*** Starting CLI:
--------------------------------------------------------------------------------
Caught exception. Cleaning up...

OSError: [Errno 12] Cannot allocate memory
--------------------------------------------------------------------------------
*** Removing excess controllers/ofprotocols/ofdatapaths/pings/noxes
killall controller ofprotocol ofdatapath ping nox_core lt-nox_core
ovs-openflowd ovs-controller udpbwtest mnexec ivs 2> /dev/null
Traceback (most recent call last):
  File "/usr/local/bin/mn", line 5, in <module>
    pkg_resources.run_script('mininet==2.2.0b2', 'mn')
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 528, in
run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1401, in
run_script
    exec(script_code, namespace, namespace)
  File
"/usr/local/lib/python2.7/dist-packages/mininet-2.2.0b2-py2.7.egg/EGG-INFO/scripts/mn",
line 387, in <module>

  File "build/bdist.linux-x86_64/egg/mininet/clean.py", line 52, in cleanup
  File "build/bdist.linux-x86_64/egg/mininet/clean.py", line 23, in sh
  File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1223, in _execute_child
    self.pid = os.fork()
OSError: [Errno 12] Cannot allocate memory
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20150314/46a6cc2c/attachment.html>


More information about the mininet-discuss mailing list