Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] [help] Switch Disconnect Automatically

Qing Wang qw at g.clemson.edu
Sun May 10 12:25:01 PDT 2015


Hey Rod,

First thanks for your response, and I do apologize for the late reply!!

Here is update:

If you try starting mininet with OF 1.0 switches, do the switches connect
correctly to the controller?
I tried OF 1.0 switches, and it gives me the error as well.

I think the problem is because some configuration problem with my OVS side.
After I created my mininet topo using "sudo mn", there is no OVS bridge
listed ( Ideally I should see one OVS bridge by default using sh ovs-vsctl
show  ).  My OVS version is 2.3.0. And it seems the OVS module is not
calling correctly by mininet for some reason.

Previously I installed mininet and OVS myself, now I downloaded the mininet
VM, and it works to me by far. There is still a 'immediate disconnect' but
after that Floodlight detect the switch in mininet and switch's DPID.

I think I will use mininet VM at this point, since it is working. But if
you like to give me some hit to fix the previous configuration, I would be
glad to try and give you feedback!

Thanks!

Qing















On Wed, May 6, 2015 at 5:44 PM, Rod N. Melton <rnm at pobox.com> wrote:

> the times where i have seen this 'immediate disconnect' problem it has
> been because the controller and switch
>
> were trying to use different versions of OpenFlow.  You should be able to
> capture the openflow messages in
>
> wireshark and see the OpenFlow version bits in the message from the switch
> and the hello message from the controller.
>
> Even though your new Floodlight supports 1.3, does it require a special
> startup flag to cause it to offer 1.3 in the
>
> initial hello message?
>
> if you try starting mininet with OF 1.0 switches, do the switches connect
> correctly to the controller?
>
>
>
> Rod
>
>
>
> On 2015-05-06 16:02, Qing Wang wrote:
>
>
> Hey there,
>
> I just start to use mininet. My goal is probably simple: I try to build a
> simple topology and use a controller to install flows onto the switch.
>
> I use the latest Floodlight controller V1.1, which support OpenFlow 1.3
> and was just announced couple days ago.
>
> And my mininet version is 2.2.1, which should also support OF 1.3, based
> on my reading.
>
> I want to just use the default topology in mininet, just to make the life
> easy. Here is my mininet commands:
>
> sudo mn --controller=remote,ip=127.0.0.1,port=6653
> --switch=ovsk,protocols=OpenFlow13
>
> The problem is: Floodlight first see a new switch, but the switch
> immediately disconnected after that. No DPID or other information was
> caught.
> Flooglight Log:
> 14:29:42.213 INFO [n.f.c.i.OFChannelHandler:New I/O worker #19] New switch
> connection from /127.0.0.1:43497
> 14:29:42.233 INFO [n.f.c.i.OFChannelHandler:New I/O worker #19] [[? from
> 127.0.0.1:43497]] Disconnected connection
>
> I tried couple things but nothing seems working by far. I read though some
> documents online, it looks to me that in the previously version Floodlight
> and Mininet the steps I listed above is all I need, at least to detect the
> connected switches.  I am not sure if the problem is on Floodlight side or
> the Mininet Side though. But I feel it is more possibly I made something
> wrong in my Mininet Configuration.
>
> I will keep poking around latter( I need to do something else now), but I
> wonder if some people have seen the same or similar problem before. Thanks
> in advance!!
>
> _______________________________________________
> mininet-discuss mailing list
> mininet-discuss at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>
>
>
>
> _______________________________________________
> mininet-discuss mailing list
> mininet-discuss at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20150510/8f9e1769/attachment.html>


More information about the mininet-discuss mailing list