Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] TCLink isn't working on kernel 4.9.0

Bob Lantz rlantz at cs.stanford.edu
Fri Dec 2 18:13:49 PST 2016


If master works, I wouldn't worry about it. The Ubuntu package really just only has to work on Ubuntu.

> On Dec 2, 2016, at 6:02 PM, Md. Islam <mislam4 at kent.edu> wrote:
> 
> Hi Bob
> 
> TCLink is not working to the Ubuntu 16 package. Could you please double check? 
> 
> I also tried Mininet from source. It can create a topology with TCLink, but ping wouldn't work. I saw some HTB related error in dmesg. Finally I just used regular link and used tc qdisc to setup the rate and delay. Here is my setup: https://github.com/tamimcse/Linux/blob/master/router.py <https://github.com/tamimcse/Linux/blob/master/router.py>
> 
> Please let me know if I'm doing anything wrong. 
> 
> Many thanks
> Tamim  
> 
> On Fri, Dec 2, 2016 at 8:43 PM, Bob Lantz <rlantz at cs.stanford.edu <mailto:rlantz at cs.stanford.edu>> wrote:
> Good to know.  Perhaps you might like to add this to the FAQ?
> 
> I would expect the Ubuntu 16 package should work fine, although it might print an error message. If not, then master should work.
> 
>> On Dec 1, 2016, at 4:53 PM, Md. Islam <mislam4 at kent.edu <mailto:mislam4 at kent.edu>> wrote:
>> 
>> I got this working after adding the following:
>> 
>> CONFIG_NET_SCH_CLK_JIFFIES=y 
>> CONFIG_NET_SCH_CLK_GETTIMEOFDAY=y
>> CONFIG_NET_SCH_CLK_CPU=y
>> CONFIG_NET_SCH_CBQ=y 
>> CONFIG_NET_SCH_HTB=y 
>> CONFIG_NET_SCH_HFSC=y 
>> CONFIG_NET_SCH_PRIO=y 
>> CONFIG_NET_SCH_RED=y 
>> CONFIG_NET_SCH_SFQ=y 
>> CONFIG_NET_SCH_TEQL=y 
>> CONFIG_NET_SCH_TBF=y 
>> CONFIG_NET_SCH_GRED=y 
>> CONFIG_NET_SCH_DSMARK=y 
>> CONFIG_NET_SCH_INGRESS=y 
>> CONFIG_NET_QOS=y
>> 
>> I also had to install Mininet from source. Mininet from the ubuntu package doesn't seem to work.
>> 
>> 
>> On Wed, Nov 30, 2016 at 11:50 PM, Md. Islam <mislam4 at kent.edu <mailto:mislam4 at kent.edu>> wrote:
>> Hi
>> 
>> I complied the kernel 4.9.0 with following option:
>> 
>> CONFIG_VETH=y
>> CONFIG_NETNS=y
>> CONFIG_NET_SCH_NETEM=y
>> 
>> sudo mn --link tc,bw=10,delay=10ms still giving me following error:
>> 
>> *** Starting 1 switches
>> s1 ...(10.00Mbit 10ms delay) *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> (10.00Mbit 10ms delay) *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> *** Error: RTNETLINK answers: No such file or directory
>> 
>> Could someone tell me what is wrong here?
>> 
>> Many thanks
>> Tamim
>> 
>> 
>> 
>> -- 
>> Tamim
>> PhD Student/Graduate Assistant
>> CS Department, Kent State University
>> Kent, OH 44240
>> http://web.cs.kent.edu/~mislam4/ <https://web.cs.kent.edu/~mislam4/>_______________________________________________
>> mininet-discuss mailing list
>> mininet-discuss at lists.stanford.edu <mailto:mininet-discuss at lists.stanford.edu>
>> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss <https://mailman.stanford.edu/mailman/listinfo/mininet-discuss>
> 
> 
> 
> 
> -- 
> Tamim
> PhD Student/Graduate Assistant
> CS Department, Kent State University
> Kent, OH 44240
> http://web.cs.kent.edu/~mislam4/ <https://web.cs.kent.edu/~mislam4/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20161202/89412da5/attachment-0001.html>


More information about the mininet-discuss mailing list