Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[mininet-discuss] installing mininet (with OVS) on Raspbian (Jessie)

Carlos Ferreira carlosmf.pt at gmail.com
Wed Dec 28 05:12:41 PST 2016


I don't think a Raspberry has enough resources to run mininet. Have you
tried your scenario script in a regular PC ?

On 27 December 2016 at 21:59, Piyush Agarwal <agarwalpiyush at gmail.com>
wrote:

> Hi,
> I am trying to install mininet (from source 2.3.0d1) on my Raspberry Pi
> running Raspbian jessie.
> Since the install script doesn't recognize Raspbian, I just commented out
> the dist check and looks like the entire mininet install (./util/install.sh
> -a) went through without any major barfs/errors.
>
> However, when I run "sudo mn --test pingall" I see the mininet is just
> completely stuck at
>
> """""""""""
> Starting 1 switches
> s1 ...
> """""""""""""
>
> I found another thread which commented about having duplicate OVS installs
> that could cause this. However, with my setup, I have ensured no OVS
> installs existed and that this is the first fresh Mininet install.
>
> I tried doing an strace but that didn't give much clue either.
>
> I have ensured "ovs-vsctl show" output is sane and "ovsdb-server" is
> running as well.
>
> What information can I provide to get some help on this. This is
> completely blocking me, so appreciate any help whatsoever.
>
> Thanks!
>
>
>
> --
> Piyush Agarwal
>
> _______________________________________________
> mininet-discuss mailing list
> mininet-discuss at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/mininet-discuss
>
>


-- 

Carlos Miguel Ferreira
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/mininet-discuss/attachments/20161228/08ffc876/attachment.html>


More information about the mininet-discuss mailing list