<html><head><meta http-equiv="Content-Type" content="text/html charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">This looks to be symptomatic of installations into a Linux container. Is this running on a virtualised environment?<div><br></div><div>AT</div><div><br></div><div><br><div><div>On 22 Apr 2014, at 10:22 pm, Fahimeh Ashrafy <<a href="mailto:fahimehashrafy@gmail.com">fahimehashrafy@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div dir="ltr"><div><div><div><div><div>Hi guys<br><br></div>when I trying to test mininet by this command   ,it returns:<br><br><i>*** Creating network<br>*** Adding controller<br>*** Adding hosts:<br>h1 h2 <br>*** Adding switches:<br>
Apr 23 01:49:18|00001|stream_unix|ERR|/tmp/stream-unix.6194.0: connection to /var/run/openvswitch/db.sock failed: No such file or directory<br>Apr 23 01:49:18|00002|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)<br>
Apr 23 01:49:19|00003|stream_unix|ERR|/tmp/stream-unix.6194.1: connection to /var/run/openvswitch/db.sock failed: No such file or directory<br>Apr 23 01:49:19|00004|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)<br>
ovs-vsctl exited with code -14<br>*** Error connecting to ovs-db with ovs-vsctl<br>Make sure that Open vSwitch is installed, that ovsdb-server is running, and that<br>"ovs-vsctl show" works correctly.<br><b>You may wish to try "service openvswitch-switch start"</b>.</i><br>
<br></div>and when I use "sudo service openvswitch-switch start" , it returns<br><br><i>FATAL: Module openvswitch not found.<br> * Inserting openvswitch module<br>Module has probably not been built for this kernel.<br>
Install the openvswitch-datapath-source package, then read<br>/usr/share/doc/openvswitch-datapath-source/README.Debian<br>FATAL: Module openvswitch not found.<br> * Inserting openvswitch module</i><br><br></div>the kenel I use 3.4 on ubuntu 12.10.<br>
<br></div>may help me?<br></div>thanks<br><div><br><br><div><br></div></div></div>
_______________________________________________<br>mininet-discuss mailing list<br><a href="mailto:mininet-discuss@lists.stanford.edu">mininet-discuss@lists.stanford.edu</a><br>https://mailman.stanford.edu/mailman/listinfo/mininet-discuss<br></blockquote></div><br></div></body></html>