Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[p4-feedback] Problems with OWL/XML files

Nick Drummond nick.drummond at cs.manchester.ac.uk
Tue Apr 14 06:44:41 PDT 2009


Hi,

I've again hand-fixed your example and roundtripped fine on build 109 on a
mac.
I'm perplexed. Is anyone else having these problems?
Can I clarify with both of you the exact system/jvm etc - this information
can be cut and pasted from the console when you start p4.
Also, could you both please check your prefixes (Edit | prefixes...) and let
me know if you have any blank prefixes or mentions of owl2xml or mappings to
http://www.w3.org/2006/12/owl2-xml#

Nick

Hello Nick,

I think the ontology was created with Protégé, though it may have been
an earlier version (and another format than OWL/XML).

I did also correct the headers by hand. After that, Protégé was able to
load the ontology, but after editing and saving it, the headers were
invalid again.

Regards,
Rörd

2009/4/12 Adam Wyner <adam at wyner.info>

>
> Hi Nick,
>
> I have the same problem as Rord and someone else with build 109 with any
> ontology I create,
> save, then try to reload.  owl2xml gets deleted *every time* I save and
> reload
> the owl files.  I'm using Protege 4 in Ubuntu.  This is a problem in the
> DOCTYPE
> declaration.
>
> Furthermore, in the Ontology definition section (after DOCTYPE), I have a
> related problem.  The line:
>
>     xmlns:owl2xml="http://www.w3.org/2006/12/owl2-xml#"
>
> is frequently truncated after saving and reloading to:
>
>     xmlns:="http://www.w3.org/2006/12/owl2-xml#"
>
> And an additional line is added later:
>
>     xmlns:=owl2xml="http://www.w3.org/2006/12/owl2-xml#"
>
> Either of these give rise to errors.
>
> When I manually edit the files to correct for these mistakes, the files
> load
> and run fine.
>
> Adam
>
>
>
> Nick Drummond wrote:
> >
> > Hi Rörd,
> >
> > 1) I've just tried in build 109 this and it appears to be rendering this
> > xml
> > entity and namespace correctly
> > <!ENTITY owl2xml "http://www.w3.org/2006/12/owl2-xml#" >
> >      xml:base="http://www.w3.org/2006/12/owl2-xml#"
> >
> > 2) Again, this is working for me for an arbitrary case. This will depend
> > on
> > your setup.
> > It sounds like the ontology URI in the file you are trying to import is
> > not
> > correct - ie doesn't match what p4 believes it to be.
> > What happens if you load it directly? What format is it?
> >
> > Have you got an example of both? Can you send me the files?
> >
> > Nick
> >
> >
> > 2009/4/5 Rörd Hinrichsen <roerd.hinrichsen at public.uni-hamburg.de>
> >
> >> Hello,
> >>
> >> I'm using Protégé 4 (build 109) with files in the OWL/XML format.
> >>
> >> I've encountered the following problems and I'd like to know if these
> >> are (known?) bugs in Protégé or what might otherwise be the problem:
> >>
> >> 1) Corrupted files:
> >>
> >> Protégé saves corrupted XML files. Inside the doctype declaration, this
> >> line:
> >>
> >>     <!ENTITY owl2xml "http://www.w3.org/2006/12/owl2-xml#" >
> >>
> >> is missing the name ("owl2xml") and inside this namespace attribute,
> >> the name ("base") is also missing:
> >>
> >>      xml:base="http://www.w3.org/2006/12/owl2-xml#"
> >>
> >> 2) Problems with importing another ontology:
> >>
> >> If I try to import the other ontology by the option "Import an
> >> ontology that is contained in one of the ontology libraries." and
> >> choose its URI, it works. But if I choose the option "Import am
> >> ontology contained in a specific file.", it doesn't work (it's
> >> displaying "(Not loaded)"), and the displayed URI of the file isn't
> >> its own, it's "http://www.w3.org/2006/12/owl2-xml" instead.
> >>
> >> Thanks in advance
> >> Rörd
> >>
> >>
> >> _______________________________________________
> >> p4-feedback mailing list
> >> p4-feedback at lists.stanford.edu
> >> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
> >>
> >
> > _______________________________________________
> > p4-feedback mailing list
> > p4-feedback at lists.stanford.edu
> > https://mailman.stanford.edu/mailman/listinfo/p4-feedback
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/Problems-with-OWL-XML-files-tp22895057p23010179.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at
> Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/p4-feedback/attachments/20090414/40e296aa/attachment.html>


More information about the p4-feedback mailing list