Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[p4-feedback] Problem saving an ontology

Nick Drummond nick.drummond at cs.manchester.ac.uk
Tue Apr 21 07:08:22 PDT 2009


It is something to do with the differentFrom likely to be down to hashing
problems.
I can't reproduce this outside of P4 unfortunately which makes it a pain to
debug.

I've added a feature request for turning off the different individuals
section. I assume you need to be able to see the individual's type otherwise
you could close the individual description view completely.

Nick

2009/4/19 S Essaid <sielists at gmail.com>

> Hello,
>
> Here is an update on this issue.  The ontology I am using has about 600
> classes and 2500 individuals. These individuals are declared all different.
> It is the combination of declaring all the individuals different and then
> attempting to render to RDF/XML that is causing the errors.  The RDF/XML
> output is just cut short at random places.  The same error also occurred if
> I try to view the RDF/XML Rendering view.  There are no errors if I use
> OWL/XML or if the individuals are not declared all different.
>
> Now that I am able to work with ontology using P4 (and only OWL/XML) I
> noticed another issue but it is somewhat expected. Every time I try to
> navigate to a different individual with the description view open the view
> has to be populated with all the 2500 different individuals and this takes
> about 10-15 seconds.  It would be useful in my case if I can disable the
> "Different individuals" portion of the description view since it does not
> contain any useful information.
>
> Thanks,
> Shahim
>
>
>
> On Fri, Apr 17, 2009 at 3:01 PM, S Essaid <sielists at gmail.com> wrote:
>
>> Hello,
>>
>> I am having problems saving the attached ontology file, I tried both
>> RDF/XML and Turtle. I am able to read the file but on save the console shows
>> the following
>>
>> Error 1 Logged at Fri Apr 17 14:53:54 PDT 2009
>> StackOverflowError: null
>>     java.util.SubList.get(Unknown Source)
>>     java.util.SubList.get(Unknown Source)   (<- repeats over 1000 times)
>>
>> I am using P4 build 109, Win XP and java 1.6.0_12
>>
>> I was able to save the same file using P3.4.  Is this a bug or a problem
>> on my side?
>>
>> Thank you,
>> Shahim
>>
>>
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/p4-feedback/attachments/20090421/2a6cd9b1/attachment.html>


More information about the p4-feedback mailing list