Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[p4-feedback] Nimbus Look'n Feel Makes Protege 4 Beta crash on Linux

Nick Drummond nick.drummond at cs.manchester.ac.uk
Wed Apr 29 04:14:34 PDT 2009


It should work - I've used this recently.
I put this in specifically for this problem.

Unless your jvm is ignoring this - I think you need to add it before "-jar
org.eclipse.osgi.jar".

Perhaps a different look and feel would be better (I don't know what is
included in your linux jre).

com.sun.java.swing.plaf.motif.MotifLookAndFeel

Nick

2009/4/28 Abdullah Battal <abdullah_battal at yahoo.com>

> Hi Nick;
> Thank you for replying, but it didn't work. I appended your line into
> run.sh but the error remained. Seems like it ignores LAF parameters, as I
> still see nimbus style scrollers around the error window.
>
>
> Hi Abdullah,
>
> You can set the look and feel in the command line (edit the script you use
> to start p4).
> add the following:
>
> *-Dswing.defaultlaf=javax.swing.plaf.metal.MetalLo**okAndFeel*
>
> Once you've successfully started p4, change the default L&F in the Window
> menu to something that works and close protege.
> You can get rid of the command line addition now.
>
> Nick
>
> 2009/4/18 Abdullah Battal <abdullah_battal at yahoo.com>
>
>> Hello;
>> I'm new to protege. I've recently downloaded protege 4 to my pc on which I
>> run Pardus Linux 2008.2.
>> Everything was going well until I changed the look'n feel of protege to
>> Nimbus (I still don't know why I needed to do that?!). Actually nothing
>> happened right away when I selected Nimbus, but then I closed Protege and,
>> after a while, I tried to re-open it and it didn't work, prompting me a
>> large error message. I tried to uninstall protege using the uninstaller and
>> then reinstall, but that didn't spare me the error message too.
>>
>> Here is what I do:
>> I follow the path to where Protege 4 is installed, and type "./Protege"
>> "Welcome to protege" screen appears. Then I want to open an ontology (a
>> new one, an existing one, from the Tones repository... it doesn't matter)
>> and the error message something like below appears:
>>
>> ERROR:
>> Error 1 Logged at Sat Apr 18 23:10:19 EEST 2009
>> NullPointerException: null
>>     java.util.Hashtable.put(Hashtable.java:394)
>>
>> javax.swing.text.SimpleAttributeSet.addAttribute(SimpleAttributeSet.java:176)
>>     javax.swing.text.StyleContext.addAttribute(StyleContext.java:293)
>>
>> javax.swing.text.StyleContext$NamedStyle.addAttribute(StyleContext.java:1488)
>>     javax.swing.text.StyleConstants.setForeground(StyleConstants.java:544)
>>
>> org.protege.editor.owl.ui.renderer.OWLCellRenderer.prepareStyles(OWLCellRenderer.java:624)
>>
>> org.protege.editor.owl.ui.renderer.OWLCellRenderer.<init>(OWLCellRenderer.java:148)
>>
>> org.protege.editor.owl.model.OWLWorkspace.createOWLCellRenderer(OWLWorkspace.java:639)
>>
>> org.protege.editor.owl.model.OWLWorkspace.createOWLCellRenderer(OWLWorkspace.java:634)
>>
>> org.protege.editor.owl.ui.find.EntityFinderField.<init>(EntityFinderField.java:77)
>>
>> org.protege.editor.owl.model.OWLWorkspace.createActiveOntologyPanel(OWLWorkspace.java:475)
>>
>> org.protege.editor.owl.model.OWLWorkspace.initialise(OWLWorkspace.java:129)
>>
>> org.protege.editor.owl.OWLEditorKit.getWorkspace(OWLEditorKit.java:103)
>>     org.protege.editor.owl.OWLEditorKit.getWorkspace(OWLEditorKit.java:43)
>>
>> org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:47)
>>
>> org.protege.editor.core.ProtegeManager.openAndSetupRecentEditorKit(ProtegeManager.java:174)
>>
>> org.protege.editor.core.ProtegeWelcomeFrame$ProtegeWelcomePanel$5.actionPerformed(ProtegeWelcomeFrame.java:233)
>>
>> org.protege.editor.core.ui.util.LinkLabel.activateLink(LinkLabel.java:97)
>>
>> org.protege.editor.core.ui.util.LinkLabel.access$100(LinkLabel.java:30)
>>
>> org.protege.editor.core.ui.util.LinkLabel$1.mouseReleased(LinkLabel.java:63)
>>     java.awt.Component.processMouseEvent(Component.java:6216)
>>     javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
>> ........GOES ON...
>>
>> Now, I would like to know if anybody else had seen this problem and if
>> there is any solution. Any help is appreciated.
>>
>> Regards.
>> --
>> Abdullah Battal.
>>
>>
> ------------------------------
> Yahoo! Türkiye açıldı!
> Haber, Ekonomi, Videolar, Oyunlar hepsi Yahoo! Türkiye'de!
> www.yahoo.com.tr <http://tr.yahoo.com/>
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/p4-feedback/attachments/20090429/6cc81bb0/attachment.html>


More information about the p4-feedback mailing list