Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[p4-feedback] Protege 4.2 build 256, fact++, , platform specific libraries issue on Debian 6

Jean-Marc Vanel jeanmarc.vanel at gmail.com
Thu Feb 16 02:22:26 PST 2012


Hi all

After I used build 249, I wanted to try latest build 256 .
But Protégé does not go beyond opening an ontology :( .
I get the a popup complaining about Fact++ platform libs.

My understanding is that my Protégé user settings, that are in a
hard-to-find location and cryptic format due to a JKD library, are
conflicting with the new build that I'm trying to start. Namely my
Protégé user settings include FACT++, but this is not provided by
default anymore in Protégé. And the plugin management is not able to
cope with this .

Here is the the begining of the console :

oem-laptop: ~/apps/w/ % protege &
[1] 3609
oem-laptop: ~/apps/w/ % Starting Protege 4 OWL Editor (Version 4.2.0,
Build = 256)
Platform:
    Java: JVM 1.7.0_01-b08 Memory: 466M
    Language: fr, Country: FR
    Framework: Apache Software Foundation (1.5)
    OS: linux (2.6.32-5-amd64)
    Processor: x86-64
Installed plugin Owlviz Plug-in
Installed plugin HermiT Reasoner
Installed plugin OWL-RDF bridge
Installed plugin OntoGraf Plug-in
Installed plugin OWL Diff Tool
Installed plugin Factplusplus Plug-in
Installed plugin SPARQL Query Plugin
Installed plugin The Protege 4 OWL Editor
Installed plugin OWL Diff Library
Installed plugin Dlquery
Installed plugin The OWL API
        OWL-RDF bridge Plugin has no plugin.xml resource
Using OWL API version 3.2.5.1912
Rebuilding entity indices...
... rebuilt in 12 ms
loading Anonymous-1 from file:/home/jmv/ontologies/foaf.rdf
Setting active ontology to <http://xmlns.com/foaf/0.1/>
Rebuilding entity indices...
... rebuilt in 6 ms
... active ontology changed
Setting active ontology to <http://xmlns.com/foaf/0.1/>
Rebuilding entity indices...
... rebuilt in 5 ms
... active ontology changed
Error logged
org.semanticweb.owlapi.model.OWLRuntimeException:
java.lang.UnsatisfiedLinkError:
/tmp/ProtegeCache-ab162723-1fa6-439e-b2ff-897fb0ef635c/bundle14/version0.0/bundle.jar-lib/0/lib/native/64bit/libFaCTPlusPlusJNI.so:
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required
by /tmp/ProtegeCache-ab162723-1fa6-439e-b2ff-897fb0ef635c/bundle14/version0.0/bundle.jar-lib/0/lib/native/64bit/libFaCTPlusPlusJNI.so)
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(Unknown
Source)
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:10)

Error 1 Logged at Thu Feb 16 10:42:53 CET 2012
OWLRuntimeException: java.lang.UnsatisfiedLinkError:
/tmp/ProtegeCache-720a4ee6-1463-4641-ae2d-e457b8965773/bundle14/version0.0/bundle.jar-lib/0/lib/native
   /64bit /libFaCTPlusPlusJNI.so: /usr/lib/libstdc++.so.6: version
`GLIBCXX_3.4.14' not found (required by
/tmp/ProtegeCache-720a4ee6-1463-4641-ae2d-e457b8965773/bundle14/version0.0/bundle.jar-lib/0/lib/native/64bit/libFaCTPlusPlusJNI.so)
    uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(Unknown
Source)

-- 
Jean-Marc Vanel
Déductions SARL - Consulting, services, training,
Rule-based programming, Semantic Web
http://jmvanel.free.fr/ - EulerGUI, a turntable GUI for Semantic Web +
rules, XML, UML, eCore, Java bytecode
+33 (0)6 89 16 29 52
chat :  irc://irc.freenode.net#eulergui


More information about the p4-feedback mailing list