Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] WebProtégé GWT version

Tania Tudorache tudorache at
Thu Dec 18 11:28:37 PST 2014

Indeed, this is a hassle. Last time I checked, WebProtege would not 
compile with GWT 2.6.1 or newer.

I added an issue in our bug tracker for upgrading the GWT version:

The workaround that I have been using for some time is to have two 
Firefox versions on my computer (v. 24 I use only for GWT development, 
and the latest one for browsing). It is fairly easy to install two 
Firefox versions, see here:

There might be other workarounds, and I am curious to know what others 
are doing.

I hope this helps for now.


On 12/18/2014 07:41 AM, Karl Hammar wrote:
> Hello all,
> I noticed the other day that the GWT Developer Plugin is now 
> deprecated by Google, due to the deprecation of the NPAPI (see wording 
> at 
> and 
> The WebProtégé Maven POM in GitHub uses GWT 2.5.1, which as far as I 
> understand, requires/makes use of the now deprecated GWT Developer 
> Plugin. Getting WebProtégé development working at the moment therefore 
> requires the use of older versions of Firefox in which the plugin can 
> still be loaded.
> Has anyone had success running WebProtégé with newer versions of GWT 
> (2.6.1 or 2.7)? Or is there some other workaround available that would 
> let me use a more recent browser with GWT 2.5.1?
> Karl
> _______________________________________________
> protege-dev mailing list
> protege-dev at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the protege-dev mailing list