Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] SWRLTab Protege 5 Maven Issue

William Fitzgerald info at williamfitzgerald.net
Wed May 20 12:14:57 PDT 2015


Dear all,

I am trying to install SWRLTab to be intergrated into the Protege5 
version as outlined in [1], however I get Maven build errors based on 
missing packages within the POM file. Any suggestions?

[1] https://github.com/protegeproject/swrltab-plugin

[+] System
I am running Ubuntu 14.04 and have installed running the following:
mvn --version
Apache Maven 3.0.5
Maven home: /usr/share/maven
Java version: 1.8.0_45, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-8-oracle/jre
Default locale: en_IE, platform encoding: UTF-8
OS name: "linux", version: "3.13.0-53-generic", arch: "i386", family: "unix"

git --version
git version 1.9.1


[+] Error

sudo mvn clean package
[INFO] Scanning for projects...
[INFO]
[INFO] 
------------------------------------------------------------------------
[INFO] Building SWRLTab Protege 5.0+ Plugin 1.0.0-SNAPSHOT
[INFO] 
------------------------------------------------------------------------
[WARNING] The POM for edu.stanford.swrl:swrlapi:jar:1.0.0-SNAPSHOT is 
missing, no dependency information available
[WARNING] The POM for 
edu.stanford.swrl:swrlapi-drools-engine:jar:1.0.0-SNAPSHOT is missing, 
no dependency information available
[INFO] 
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 1.086s
[INFO] Finished at: Wed May 20 20:08:08 IST 2015
[INFO] Final Memory: 7M/106M
[INFO] 
------------------------------------------------------------------------
[ERROR] Failed to execute goal on project swrltab-plugin: Could not 
resolve dependencies for project 
edu.stanford.swrl:swrltab-plugin:bundle:1.0.0-SNAPSHOT: The following 
artifacts could not be resolved: 
edu.stanford.swrl:swrlapi:jar:1.0.0-SNAPSHOT, 
edu.stanford.swrl:swrlapi-drools-engine:jar:1.0.0-SNAPSHOT: Could not 
find artifact edu.stanford.swrl:swrlapi:jar:1.0.0-SNAPSHOT -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the 
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, 
please read the following articles:
[ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException


Any ideas?

Will.

-- 
Dr. William M. Fitzgerald (B.Sc., M.Sc., Ph.D.)
Senior Research Scientist – Cyber Security
United Technologies Research Centre Ireland
4th Floor, Penrose Business Centre,
Penrose Wharf,
Cork, Ireland
Email: fitzgew at utrc.utc.com
Web (UTRC): http://www.utrc.utc.com
Web (Personal): http://www.williamfitzgerald.net
--
Disclaimer: Content published from my private Email domain does not necessarily reflect the views and opinions of UTRC nor does it constitute any official communication of UTRC.
--



More information about the protege-dev mailing list