Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] building a Protege distro with Eclipse on Mac

idioma corda.ilaria at gmail.com
Thu May 28 07:38:22 PDT 2015


Hi,
after some tribulations, I seem to have managed to build my Protege distro
(4.1) with Eclipse Luna 4.4.2 (JDK 1.7.0_51) on Mac OSX Yosemite 10.10.3. I
have created my PROTEGE_HOME, which currently points to
PROTEGE_HOME=/Users/UserName/Documents/protege4.1-distro/protege-base. I
have then run the protege_base.xml ant file and although builds
successfully, it returns the following errors: 

init:
     [echo] **********************************************************
     [echo] Using Protege Home =
/Users/UserName/Documents/workspace/protege-base/${env.PROTEGE_HOME}
     [echo] Using Java Version = 1.7
     [echo] **********************************************************
run:
     [java] /Users/UserName/Documents/workspace/protege-base/build.xml:111:
/Users/UserName/Documents/workspace/protege-base/${env.PROTEGE_HOME} is not
a valid directory
     [java] 	at
org.apache.tools.ant.taskdefs.Java.setupWorkingDir(Java.java:855)
     [java] 	at
org.apache.tools.ant.taskdefs.Java.setupExecutable(Java.java:825)
     [java] 	at org.apache.tools.ant.taskdefs.Java.fork(Java.java:788)
     [java] 	at
org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:214)
     [java] 	at
org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:135)
     [java] 	at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
     [java] 	at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
     [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] 	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
     [java] 	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     [java] 	at java.lang.reflect.Method.invoke(Method.java:606)
     [java] 	at
org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
     [java] 	at org.apache.tools.ant.Task.perform(Task.java:348)
     [java] 	at org.apache.tools.ant.Target.execute(Target.java:435)
     [java] 	at org.apache.tools.ant.Target.performTasks(Target.java:456)
     [java] 	at
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1393)
     [java] 	at
org.apache.tools.ant.Project.executeTarget(Project.java:1364)
     [java] 	at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
     [java] 	at
org.eclipse.ant.internal.launching.remote.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:36)
     [java] 	at
org.apache.tools.ant.Project.executeTargets(Project.java:1248)
     [java] 	at
org.eclipse.ant.internal.launching.remote.InternalAntRunner.run(InternalAntRunner.java:452)
     [java] 	at
org.eclipse.ant.internal.launching.remote.InternalAntRunner.main(InternalAntRunner.java:139)
     [java] Java Result: -1
BUILD SUCCESSFUL

My question is, has the protege distro been correctly built and compiled? 

Thank you,

I.



--
View this message in context: http://protege-project.136.n4.nabble.com/building-a-Protege-distro-with-Eclipse-on-Mac-tp4663014.html
Sent from the Protege Developer mailing list archive at Nabble.com.


More information about the protege-dev mailing list