Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] I'm having problems when I try to debug from the IDE

Manuel Enrique Puebla Martinez mpuebla at uci.cu
Wed Feb 8 12:37:48 PST 2017



Hello: 


I have no problem, when I make an "mvn clean package" to the original Protégé code. I managed to execute and debug without any problem, because of that I was able to learn how Protégé works. The problem occurs when I add my class and enumerative package. It compiles well, but when I try to execute or debug, the error already commented appears. If you consider it, I can send you my project with the changes made to the source code of Protégé, there are not many so far. I just modified the "refill" method of the "OWLDataPropertyAssertionAxiomFrameSection" class that is in 
"Org.protege.editor.owl.ui.frame.individual", in order to extract the "Property assertions" from my ontology that are in a Databases and not in the OWL file. 



Attached file "protect.log". 


I am incorporating functionalities into the Protégé project. But I'm having problems when I try to debug from the IDE Eclipse. 


I added a package called "org.protege.editor.owl.bigontology", inside I added my classes and enumerative types. Everything compiles well when I do an "mvn clean package", I attach an image of the result in the console. However, when I try to debug from Eclipse, I get an error message: "An error occurred that prevent Protégé from Starting", also attached the image. " 


I have been reviewing the code and detected that the exception is thrown in the line "framework.start ();", belonging to the method "start", class "Launcher". 

Within the "start" method, the error occurs when the following line of code is executed: 
"// Send a framework event to indicate the framework has started. 
FireFrameworkEvent (FrameworkEvent.STARTED, this, null); " 

Within the "fireFrameworkEvent" method, only the following line of code is executed: 
"M_dispatcher.fireFrameworkEvent (new FrameworkEvent (type, bundle, throwable));" 

"Type" = 1, "bundle" is an information object and "throwable" = null; 

Any help that allows me to identify the reason for the error? 







Best regards. 









La @universidad_uci es Fidel. Los jóvenes no fallaremos.
#HastaSiempreComandante
#HastalaVictoriaSiempre

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-dev/attachments/20170208/6306b865/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: protege.log
Type: text/x-log
Size: 10534 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-dev/attachments/20170208/6306b865/attachment.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Eclipse Error.png
Type: image/png
Size: 200338 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-dev/attachments/20170208/6306b865/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cmdError.jpg
Type: image/jpeg
Size: 335004 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-dev/attachments/20170208/6306b865/attachment.jpg>


More information about the protege-dev mailing list