Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] I'm having problems when I try to debug from the IDE

Josef Hardi johardi at stanford.edu
Fri Feb 10 08:22:53 PST 2017


What is your Github address for the project?

Best,
Josef

On Feb 8, 2017, at 12:37 PM, Manuel Enrique Puebla Martinez <mpuebla at uci.cu<mailto:mpuebla at uci.cu>> wrote:

Hello:
I have no problem, when I make an "mvn clean package" to the original Protégé code. I managed to execute and debug without any problem, because of that I was able to learn how Protégé works. The problem occurs when I add my class and enumerative package. It compiles well, but when I try to execute or debug, the error already commented appears. If you consider it, I can send you my project with the changes made to the source code of Protégé, there are not many so far. I just modified the "refill" method of the "OWLDataPropertyAssertionAxiomFrameSection" class that is in
"Org.protege.editor.owl.ui.frame.individual", in order to extract the "Property assertions" from my ontology that are in a Databases and not in the OWL file.

 Attached file "protect.log".
 I am incorporating functionalities into the Protégé project. But I'm having problems when I try to debug from the IDE Eclipse.
 I added a package called "org.protege.editor.owl.bigontology", inside I added my classes and enumerative types. Everything compiles well when I do an "mvn clean package", I attach an image of the result in the console. However, when I try to debug from Eclipse, I get an error message: "An error occurred that prevent Protégé from Starting", also attached the image. "
 I have been reviewing the code and detected that the exception is thrown in the line "framework.start ();", belonging to the method "start", class "Launcher".

Within the "start" method, the error occurs when the following line of code is executed:
"// Send a framework event to indicate the framework has started.
         FireFrameworkEvent (FrameworkEvent.STARTED, this, null); "

Within the "fireFrameworkEvent" method, only the following line of code is executed:
"M_dispatcher.fireFrameworkEvent (new FrameworkEvent (type, bundle, throwable));"

"Type" = 1, "bundle" is an information object and "throwable" = null;

Any help that allows me to identify the reason for the error?


Best regards.





________________________________
La @universidad_uci es Fidel. Los jóvenes no fallaremos. #HastaSiempreComandante #HastalaVictoriaSiempre

<protege.log><Eclipse Error.png><cmdError.jpg>_______________________________________________
protege-dev mailing list
protege-dev at lists.stanford.edu<mailto:protege-dev at lists.stanford.edu>
https://mailman.stanford.edu/mailman/listinfo/protege-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-dev/attachments/20170210/0a1b52d3/attachment.html>


More information about the protege-dev mailing list