Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] about OSGI, maven and Prot?g? (Lorenz B.)

Manuel Enrique Puebla Martinez mpuebla at
Thu Feb 23 06:03:44 PST 2017


Thanks for answering. But it was a mistake on my part, the soft space before the $ sign does not appear in the source code. That is, it appears as you say ($ {include.resources}) and still it still generates an error.

I also have other errors that I forgot to comment, here they go:

  In the line of code:
"<Export.packages> $ {export.package} *; version = $ {unpack.version} </ export.packages>"
My maven does not recognize "export.package", nor does it recognize "unpack.version". By intuition I changed to "export.package" by "export.packages", I do not know if it is correct.

For "unpack.version" I have not found substitute, although I tried with "project.version", I do not know if it is correct.

Also, when I do "mvn clean package", it gives me error with the file pom.xml

Some help?

Best regards.

Message: 2
Date: Thu, 23 Feb 2017 09:14:11 +0100
From: "Lorenz B." <spo05hyn at>
Subject: Re: [OWLAPI-developer] about OSGI, maven and Prot?g?
To: owlapi-developer at
	<0bc98f73-1b9e-fdde-8600-5468fbd105f3 at>
Content-Type: text/plain; charset="utf-8"

the white space

> Looking for information I found what I needed: specific documentation on how to use new maven dependencies (not OSGI) in the Prot?g? project (it's OSGI). I found this URL:
> Http://
> However, I have the following problem:
> I'm making some changes to the Prot?g? project (using OSGI and maven), changes involve the use of new maven dependencies in the "prot?g?-editor-owl" Bundle. I have tried to use this example but I have an error:
> I made the changes in the "pom.xml" file of the parent Bundle of "prot?g?-editor-owl" (prot?g?-parent) and then in the "pom.xml" of "prot?g?-editor-owl". Intellij IDEA informs me of the following: it can not resolve the "include.resources" symbol, in the following line: "<Include-Resource> $ {include.resources} </Include-Resource>".
after the $ sign, there must be no white space, i.e. instead of

$ {include.resources}



> Some help?
> Best Regards.
La @universidad_uci es Fidel. Los jóvenes no fallaremos.

More information about the protege-dev mailing list