Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-dev] [Plugin] Incompatibilities with JavaFX?

Lorenz Buehmann buehmann at informatik.uni-leipzig.de
Mon Feb 24 02:43:54 PST 2020


that's clearly wrong in your Maven Bundle plugin config. I mean, look at
the package name

org.osgi.framework.system.packages.extra=javafx.embed.swing.JFXPanel;version

it should just be 

javafx.embed.swing.JFXPanel;version=

with a correct version number ideally.  

On 24.02.20 11:38, mistermboy wrote:
> Hi! Thanks for answering. I am trying to fix it doing something like this in
> the Maven bundle plugin config:
>
> <Import-Package>
>      org.protege.editor.owl.*;version="5.0.0", 						 
>     
> org.osgi.framework.system.packages.extra=javafx.embed.swing.JFXPanel;version="0.0.0",
>      *
> </Import-Package>
>
> But when I run"mvn clean package" I get this message:
>
> [WARNING] Bundle
> edu.stanford.protege:protege.plugin.examples:bundle:2.0.0-SNAPSHOT : Invalid
> package name:
> 'org.osgi.framework.system.packages.extra=javafx.embed.swing.JFXPanel'
>
>
>
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-Developer-f4659816.html
> _______________________________________________
> protege-dev mailing list
> protege-dev at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-dev


More information about the protege-dev mailing list