<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Indeed, this is a hassle. Last time I checked, WebProtege would not
    compile with GWT 2.6.1 or newer.<br>
    <br>
    I added an issue in our bug tracker for upgrading the GWT version:<br>
    <a class="moz-txt-link-freetext" href="https://github.com/protegeproject/webprotege/issues/224">https://github.com/protegeproject/webprotege/issues/224</a><br>
    <br>
    The workaround that I have been using for some time is to have two
    Firefox versions on my computer (v. 24 I use only for GWT
    development, and the latest one for browsing). It is fairly easy to
    install two Firefox versions, see here:<br>
<a class="moz-txt-link-freetext" href="http://stackoverflow.com/questions/1111920/multiple-firefox-versions-on-same-pc">http://stackoverflow.com/questions/1111920/multiple-firefox-versions-on-same-pc</a><br>
    <br>
    There might be other workarounds, and I am curious to know what
    others are doing. <br>
    <br>
    I hope this helps for now.<br>
    <br>
    Tania<br>
    <br>
    <br>
    <br>
    <br>
    <div class="moz-cite-prefix">On 12/18/2014 07:41 AM, Karl Hammar
      wrote:<br>
    </div>
    <blockquote
cite="mid:CADPQx=AXTkb4YOfspOipvkMiiEE4tTtQcKvG72QzVvsKdGOc0g@mail.gmail.com"
      type="cite">
      <div dir="ltr">Hello all,
        <div><br>
        </div>
        <div>I noticed the other day that the GWT Developer Plugin is
          now deprecated by Google, due to the deprecation of the NPAPI
          (see wording at <a moz-do-not-send="true"
href="https://chrome.google.com/webstore/detail/gwt-developer-plugin/jpjpnpmbddbjkfaccnmhnkdgjideieim">https://chrome.google.com/webstore/detail/gwt-developer-plugin/jpjpnpmbddbjkfaccnmhnkdgjideieim</a> and <a
            moz-do-not-send="true"
            href="http://www.chromium.org/developers/npapi-deprecation">http://www.chromium.org/developers/npapi-deprecation</a>). </div>
        <div><br>
        </div>
        <div>The WebProtégé Maven POM in GitHub uses GWT 2.5.1, which as
          far as I understand, requires/makes use of the now deprecated
          GWT Developer Plugin. Getting WebProtégé development working
          at the moment therefore requires the use of older versions of
          Firefox in which the plugin can still be loaded.</div>
        <div><br>
        </div>
        <div>Has anyone had success running WebProtégé with newer
          versions of GWT (2.6.1 or 2.7)? Or is there some other
          workaround available that would let me use a more recent
          browser with GWT 2.5.1?</div>
        <div><br>
        </div>
        <div>Karl</div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
protege-dev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:protege-dev@lists.stanford.edu">protege-dev@lists.stanford.edu</a>
<a class="moz-txt-link-freetext" href="https://mailman.stanford.edu/mailman/listinfo/protege-dev">https://mailman.stanford.edu/mailman/listinfo/protege-dev</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>