Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] NumberFormatException during installation!

Tania Tudorache tudorache at stanford.edu
Mon Oct 9 12:12:19 PDT 2006


Adam,

I am also using Ubuntu 6.06 for Protege development. What I think it 
happens, is that even if you installed Sun JDK 1.5, Ubuntu uses the GNU 
free java by default, and InstallAnywhere (the Protege install 
application) does not work with the free java. You need to configure the 
sun jvm to be the default one, like it is described here:

https://help.ubuntu.com/community/Java#head-fef9352fb26820bb774df978180c9dd3a60e777b

Then, try to reinstall protege with the install script. It worked for me :)

Tania


Adam Funk wrote:
> I've tried several of the Linux installers on the Protégé download
> page, but they always fail with this:
>
>
> $ sh install_protege.bin 
> Preparing to install...
> Extracting the installation resources from the installer archive...
> Configuring the installer for this system's environment...
>
> Launching installer...
>
> An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)
>
> Stack Trace:
> java.lang.NumberFormatException: invalid character at position 1 in @\h:
>    at java.lang.Integer.parseInt(libgcj.so.7)
>    at java.lang.Integer.parseInt(libgcj.so.7)
>    at java.util.Properties.load(libgcj.so.7)
>    at com.zerog.common.java.util.PropertiesUtil.loadProperties(DashoA8113)
>    at com.zerog.lax.LAX.<init>(DashoA8113)
>    at com.zerog.lax.LAX.main(DashoA8113)
>
>
> This is a current Ubuntu system with the Sun JDK 1.5.0_05.  I've
> googled around for this error but can't find any information.  Has
> anyone else seen this?  Any suggestions?
>
> Thanks,
> Adam
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
>
>   




More information about the protege-discussion mailing list