Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] NumberFormatException during installation!

Adam Funk a24061 at yahoo.com
Tue Oct 10 02:52:55 PDT 2006


On 2006-10-09, Tania Tudorache <tudorache at stanford.edu> wrote:

> I am also using Ubuntu 6.06 for Protege development. What I think it 
> happens, is that even if you installed Sun JDK 1.5, Ubuntu uses the GNU 
> free java by default, and InstallAnywhere (the Protege install 
> application) does not work with the free java. You need to configure the 
> sun jvm to be the default one, like it is described here:

I thought I'd done that...

> https://help.ubuntu.com/community/Java#head-fef9352fb26820bb774df978180c9dd3a60e777b

...but that's more thorough.

> Then, try to reinstall protege with the install script. It worked for me :)

I'm getting a bit farther through the install now, but it dies with
this error:

$ sh install_protege.bin 
Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)

Stack Trace:
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
        at java.util.Properties.loadConvert(Properties.java:492)
        at java.util.Properties.load(Properties.java:331)
        at com.zerog.common.java.util.PropertiesUtil.loadProperties(DashoA8113)
        at com.zerog.lax.LAX.<init>(DashoA8113)
        at com.zerog.lax.LAX.main(DashoA8113)


I've tried it with both  LANG=en_GB.UTF-8  (my default) and
en_GB.iso885915 with the same failure both ways.

I hope you have another good suggestion!

Thanks,
Adam




More information about the protege-discussion mailing list