Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] NumberFormatException during installation!

Adam Funk a24061 at yahoo.com
Mon Oct 23 08:21:31 PDT 2006


> Adam Funk wrote:

>> I'm getting a bit farther through the install now, but it dies with
>> this error:
>>
>> $ sh install_protege.bin 
>> Preparing to install...
>> Extracting the installation resources from the installer archive...
>> Configuring the installer for this system's environment...
>>
>> Launching installer...
>>
>> An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)
>>
>> Stack Trace:
>> java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
>>         at java.util.Properties.loadConvert(Properties.java:492)
>>         at java.util.Properties.load(Properties.java:331)
>>         at com.zerog.common.java.util.PropertiesUtil.loadProperties(DashoA8113)
>>         at com.zerog.lax.LAX.<init>(DashoA8113)
>>         at com.zerog.lax.LAX.main(DashoA8113)

Tania Tudorache <tudorache at stanford.edu> wrote:

> Unfortunately, I'm not a Linux expert. I still think that 
> InstallAnywhere is using the wrong jvm.


This error turned out not to be related to java versions, but it was
pretty obscure (for me).  Someone else (our local InstallAnywhere
expert) identified and fixed this problem for me; I'm just posting
this "for the record" in case it helps anyone else.

My ~/.bashrc file contains these lines:

   TITLEBAR='\[\033]0;\u@\h:\w\007\]'
   PS1="$TITLEBAR"'\n\u@\h : $PWD \$ '

so that the tops of my xterm windows show 'adam at computer:~/bin' for
example.  The value of TITLEBAR was getting picked up by
InstallAnywhere and recorded in the system properties somewhere in
/tmp, then read later as an invalid encoded Unicode character.  (I
still don't understand why it had worked on my other computer, which
uses the same thing.)

Anyway, he fixed it by running the installer this way:

  TITLEBAR=   sh install_progete.bin

Thanks,
Adam




More information about the protege-discussion mailing list