Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] ProtegeOWL.createJenaOWLModelFromURI

Thang Duong protegeinfo at gmail.com
Mon Apr 9 02:52:32 PDT 2007


For everybody who is insteresting:

When i use :

OWLModel model = null;
model = ProtegeOWL.createJenaOWLModelFromURI(this.ONTOLOGY_URL);

I have an error:
Warning: SystemUtilities.loadDirectoryManifest(D:\SemanticWeb\plugins)
Unable to load
Protege-2000  version 1.7, Build 930
JVM: Java HotSpot(TM) Client VM - 1.5.0_11-b03, mixed mode
Plugin classpath:
    file:/D:/SemanticWeb/plugins/

Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError:
edu/stanford/smi/protege/model/framestore/FrameStore
        at
edu.stanford.smi.protegex.owl.jena.JenaKnowledgeBaseFactory.createKnowledgeBase
(JenaKnowledgeBaseFactory.java:55)


I searched on the internet, they said using classpath pointing to Proteger
dir which is set up in my computer. If I have no protege dir in my computer,
i just have only "plugins\edu.stanford.smi.protegex.owl", which contains
jars file for programming with Protege OWL, so how can I reset the path of
Protege plugins before using:

model = ProtegeOWL.createJenaOWLModelFromURI(this.ONTOLOGY_URL);

Because if i can not reset the path of Protege plugins, the program will
have the following error:

Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError:
edu/stanford/smi/protege/model/framestore/FrameStore


Duong Quoc Thang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20070409/371d9f41/attachment.html>


More information about the protege-discussion mailing list