Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Missing map instance warnings from GraphWidget

Jonathan Carter jonathan.carter at e-asolutions.com
Thu Dec 20 11:09:56 PST 2007


Hi Samson,

OK, so to make sure I understand, if I create a graph in a client, when I
come to open it again, the server cannot serve me the locations/sizes etc.
and so everything reverts to default (at least it doesn't fail or crash!)?

What I've got is a project that was created in stand-alone mode, including
some graphs and now I'm using this project in client-server mode and even
all the graph properties that I can see in the server project files are not
'sent down' to the clients. So, effectively, I've started with what you
suggested as the solution but am still having problems. If I open the
server's project locally on the server in stand-alone mode, everything is
fine with my graphs. I saved this standalone project to a new version on the
server and used this for client-server mode, but I am still getting the
warnings from my clients.

Do you know if there are any plans to resolve this at some point? Or are
there any pointers/thoughts as to what the solution is? I'd be happy to help
resolve the issue.

Thanks again for your help

Jonathan

__________________________________________
Jonathan Carter - Head of Technical Architecture
Enterprise Architecture Solutions Ltd
Mobile: +44 (0) 7904 198295
Email: jonathan.carter at e-asolutions.com
__________________________________________

Assess your EA maturity at:
www.enterprise-architecture.com/EAvaluator
__________________________________________



-----Original Message-----
From: protege-discussion-bounces at lists.stanford.edu
[mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Samson
Tu
Sent: 20 December 2007 17:26
To: protege-discussion at lists.stanford.edu
Subject: Re: [protege-discussion] Missing map instance warnings from
GraphWidget


You need to open the project in standalone mode and re-position/re-size
nodes and links in the graph. The server doesn't know anything about the
graph-widget layout information entered on the client side. It is a known
issue in the use of graph widget in client/server mode.

Samson


Jonathan Carter wrote:
> Hi,
>  
> I've been using Protege for some time in both stand-alone and in 
> client-server modes with great success.
> I recently deployed a new project that has been developed over some 
> time in stand-alone mode to a new client-server environment. 
> Currently, the server is using a file-based project while I am waiting 
> for the DBAs to allocate me a database to use.
> When I access my project via a client that is running either on the 
> server (a localhost-style client) or running on a physically remote 
> machine, I get the following 'Missing map instance' warnings. These 
> map instances turn out to be the saved x, y, locations and dimensions 
> of artefacts created using the Graph Widget. I don't seem to be losing 
> these artefacts, but all resizing and positioning of these shapes is 
> lost for the clients.
> Having had a look through the discussions history, I've tried 
> re-saving this project on the server but am still getting these 
> warnings on the client Protege 'console' and my GraphWidget shapes 
> have lost all their location and sizing properties.
>  
> Is this a bug with the GraphWidget in client-server mode, a known 
> issue or something I've got wrong in the metaproject?
>  
> Warning messages follow:
>  
> ...
> CONFIG: Loaded plugin uk.ac.man.cs.mig.coode.protege.wizard.owl - OWL 
> Wizards
> CONFIG: Preloading frame values
> CONFIG: Preloading frame values
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2704
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2716
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2725
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2728
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2734
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2736
> -- Proper
> tyMapUtil.getMap()
> WARNING: Missing map instance: zzz_live_v1.4.2_ProjectKB_Instance_2742
> -- Proper
> tyMapUtil.getMap()
>  
> [.... LOTS MORE OF THESE WARNINGS! ....]
>  
> WARNING: Missing map instance: anl_live_v1.4.2_ProjectKB_Instance_3484
> -- Proper
> tyMapUtil.getMap()
> WARNING: null -- WidgetUtilities.isSuitableExport()
> CONFIG: Preloading frame values
> ...
>  
> Thanks for your help
>  
> Regards
>  


-- 
Samson Tu                                   email: swt at stanford.edu
Senior Research Scientist                   web: www.stanford.edu/~swt/
Center for Biomedical Informatics Research  phone: 1-650-725-3391
Stanford University                         fax: 1-650-725-7944

_______________________________________________
protege-discussion mailing list
protege-discussion at lists.stanford.edu
https://mailman.stanford.edu/mailman/listinfo/protege-discussion

Instructions for unsubscribing:
http://protege.stanford.edu/doc/faq.html#01a.03 





More information about the protege-discussion mailing list