Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Protege server problem working with owl classes

Tania Tudorache tudorache at stanford.edu
Tue Feb 6 14:13:36 PST 2007


Juan,

This is indeed a bug. I have created a bug reported and added it to 
Bugzilla:

http://smi-protege.stanford.edu/bugzilla/show_bug.cgi?id=380

This appears only in the case that you are using the files backend (so, 
an OWL file on the server side). It is recommended that you use the 
database backend in the client-server mode in which this bug does not 
come up.

Please ask in future OWL related questions on the OWL mailing list.

Thanks,
Tania


Juan A. Recio wrote:
> Hello.
> I'm working in client-server mode to create an OWL ontology. I can add and
> remove classes, but I cannot delete conditions of the concepts.
>
> For example:
> I create a class "class_1" and its subclass "class_2". In the asserted
> conditions of "class_2" you have "class_1" in the "Necessary" conditions
> list because it is the parent concept. When I edit the ontology in
> standalone mode (without the server) I can choose that condition and delete
> it using the "Delete selected row" button (that way, "class_2" isn't now a
> subclass of "class_1"), but in client-server mode that button is disabled.
>
> Is it any kind of desing restriction, bug, or server configuration problem?
> I have been reading the messages in the discussion list but I couldn't find
> anything.
>
> Thank you very much in advance,
> Juan A. Recio.
>
>   




More information about the protege-discussion mailing list