Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Question about Protégé UI Slowness

Schultz, Ron ron.schultz at vectorsgi.com
Thu Mar 8 08:27:01 PST 2007


I have noticed a Protégé performance anomaly a number of times, and was wondering if anyone else has ever reported this. I am using Java 5, Protégé 3.2, and am allocating Protégé 512M of memory on Windows XP (on a desktop with 2 gigabytes available RAM). My ontology is < 500 instances and < 100 classes and < 100 slots, and is in CLIPS format. The symptom I occasionally see is that the UI will sometimes get unresponsive and slow. Mouse movements across the Protégé Windows will be jerky and delayed, and data entry windows will sometimes take 10-15 seconds to accept input. Sometimes it gets so slow that each keystroke can take up to 5 seconds to render into a text box.  No errors or log messages appear in the Java log console. Restarting Protégé takes care of the issue, so this is not a severe issue, but I was wondering if anyone has seen this also, and any idea why this occurs. 

Thanks

Ron Schultz


[This message contains confidential and proprietary information of the sender, and is intended only for the person(s) to whom it is addressed.  Any use, distribution, copying or disclosure by any other person is strictly prohibited.  If you have received this message in error, please notify the e-mail sender immediately, and delete the original message without making a copy.]



More information about the protege-discussion mailing list