Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] ModelFactory error

Davenport, Daniel daniel.davenport at lmco.com
Fri Oct 5 08:11:40 PDT 2007


I ran my code with the class generated by Protégé for my ontology and got this messge

 

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

      at com.hp.hpl.jena.rdf.model.impl.PropertyImpl.<clinit>(PropertyImpl.java:61)

      at com.hp.hpl.jena.enhanced.BuiltinPersonalities.<clinit>(BuiltinPersonalities.java:28)

      at com.hp.hpl.jena.rdf.model.impl.ModelCom.<init>(ModelCom.java:51)

      at com.hp.hpl.jena.rdf.model.ModelFactory.createDefaultModel(ModelFactory.java:162)

      at com.hp.hpl.jena.rdf.model.ModelFactory.createDefaultModel(ModelFactory.java:156)

      at com.hp.hpl.jena.rdf.model.impl.ModelSpecImpl.<clinit>(ModelSpecImpl.java:56)

      at lantern.test.<clinit>(test.java:18)

      at lantern.Lantern.main(Lantern.java:23)

 

I used the right libraries

 

import com.hp.hpl.jena.rdf.model.*;

import com.hp.hpl.jena.ontology.*;

 

so it compiled alright.  Im running it on Eclipse.  So what am I missing?

 

-Dan 

 

Daniel M. Davenport, PhD

Principal Research Engineer

Advanced Technology Office

Lockheed Martin Information Systems & Global Services

King of Prussia, PA

Email: Daniel.Davenport at lmco.com

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20071005/942a620b/attachment.html>


More information about the protege-discussion mailing list