Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] problem with Java API of protege - frames 3.3.1

Antonia Iliopoulou antonia.iliopoulou at gmail.com
Thu May 15 23:10:50 PDT 2008


Hello,

I am trying to develop a java application (in netBeans 6.1)  using the java
API of protege frames. My protege project is made withe version 3.3.1. When
I run the application I get the following errors :

*Warning: Cannot set console log debugger handler.
**Warning: IO exception getting logger. Could not initialize class
**edu.stanford.smi.protege.util.ApplicationProperties
**Exception in thread "main" java.lang.NoClassDefFoundError:
**com/jgoodies/looks/plastic/PlasticTheme at
**edu.stanford.smi.protege.model.Project.<clinit>*
**
I read in a thread in this mailing list that previous jars didn't have this
problem. So I uninstalled the protege 3.3.1 and I installed the protege
3.2.1. And indeed this problem disappeared. But now I have another problem
which I do not know how to solve. The error I get from netbeans is :

*SEVERE: non-existent slot: undo_enabled -- Parser.recordError()
WARNING: no such class:
edu.stanford.smi.protegex.storage.rdf.configurable.RDFCBackend --
SystemUtilities.newInstance()
SEVERE: Cannot find knowledgebase factory:
edu.stanford.smi.protegex.storage.rdf.configurable.RDFCBackend
Error: non-existent slot: undo_enabled
Please check that you have the required plug-in. -- Project.createDomainKB()
Error: **edu.stanford.smi.protege.util.MessageError at 15ee671*<edu.stanford.smi.protege.util.MessageError at 15ee671>
I also get the same problem from protege when I try to open my protege
project.


So, my questions are:

1. Why proetege 3.3.1 had the above problem ? Isn't there a way to work with
the java API of this version?
2. Is it necessary to use the older version in order to create my java
application?
3. And if it necessary how can I solve the problem I have? There isn't
backward compatibility between protege version?
Your help is crucial!

Thank you in advance,
Antonia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20080516/04a15fc9/attachment.html>


More information about the protege-discussion mailing list