Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Problem using Forms Tab in Collaborative mode

Tomas Potok potok at kopernik.cc.fmph.uniba.sk
Tue May 27 13:58:22 PDT 2008


Thanks for the reply,

indeed, it's very inconvenient that I need to shut down the server, change the
Forms and restart it again (I assume that's necessary). In my current use case
I'd like to change the classes (and Forms) and fill in the instances at the same
time (continuous class model evolution along with usage).

I think this should be solved on the permission level, i.e. certain users would
be permitted to do changes to the Forms.

Thanks, Tomas.


On Tue, 27 May 2008, Jonathan Carter wrote:

> This is expected behaviour and it intentional on the basis that a
> "superuser" or "admin" can control the forms by directly accessing the
> Project in stand-alone mode to manage the GUI. Having many users
> attempting to edit the forms at once could cause all sorts of
> problems, I would imagine.
> For what I'm doing, this works ideally. I can modify the forms as I
> need to then start up the server to have my users work on Classes and
> Instances in multi-user mode and I can control the GUI and make sure
> that it's consistent. Although I realise that it would convenient to
> be able to edit the Forms from client-server mode, I would have a lot
> of concerns about how the Forms would or could turn out if they were
> available to all users.
>
> Hope this helps
>
> Jonathan
> __________________________________________
> Jonathan Carter - Head of Technical Architecture
> Enterprise Architecture Solutions Ltd
> __________________________________________
>
> Assess your EA maturity at:
> www.enterprise-architecture.com/EAvaluator
> __________________________________________
>
> On 25 May 2008, at 01:26, Tomas Potok wrote:
>
> > Hello!
> >
> > I'm running the Protege server (tried 3.3.1 and 3.4beta) and
> > I cannot turn the "FormsTab" in "Project / Configure..." on
> > (when connected to the server remotely). There's even no reason for
> > tab
> > unavailability displayed (for others there's one). Simply greyed
> > out.
> >
> > Windows XP, standard out-of-the-box setup.
> >
> > Help greatly appreciated.
> >
> > Thanks
> >
> > Tomas
> >
> > --
> > Also doing mathematics this way?
> > http://kopernik.cc.fmph.uniba.sk/~potok/jokes/math.jpg
> > _______________________________________________
> > protege-discussion mailing list
> > protege-discussion at lists.stanford.edu
> > https://mailman.stanford.edu/mailman/listinfo/protege-discussion
> >
> > Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03
>
>



More information about the protege-discussion mailing list