Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] WebProtege Installation

Firedrop 84 firedrop84 at hotmail.com
Sat Apr 18 04:05:30 PDT 2009


Ron, 

 

everything that I installed is on my laptop (Protege, Tomcat, etc). 

 

When I run the run_protege.bat and it opened the protege application. Does Protege Clients means the application. If so, how can I connect to the server when I run the client. 

 

I usually run the run_protege_server.bat to run the protege server and it never ask me for any username or password.

 

I created a small jsp file just to test tomcat and it worked fine. Then, I checked the file that you told me about under webapps directory (webproteg.jar) but I can't find it there or anywhere in my computer.

 

Then, I checked the webprotege folder and I have all the folders such ass css, images, js, etc. Most of the jar files was under lib or WEB-INF\lib but nothing called webprotege.jar.

 

Then I checked the log files that you told me to check and I couldn't find errors. This is what I have in the log files

 

catalina.2009-04-18.log

 

18-Apr-2009 00:33:44 org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/webprotege]
18-Apr-2009 00:44:26 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
18-Apr-2009 00:44:27 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
18-Apr-2009 00:44:28 org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080


 

localhost.2009-04-18.log 

 

18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
18-Apr-2009 00:44:28 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:28 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()

 


From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Fri, 17 Apr 2009 13:55:46 -0500
Subject: Re: [protege-discussion] WebProtege Installation







Ahmed,
 
If your Protégé Server displays: “Protégé server ready to accept connections. . .” then the Protégé server is running fine. You can verify access and firewall rules by running a Protégé client and connecting to the server itself from the same machine you intend to run Tomcat from. Just run run_protege.bat and connect to localhost using the username and password you put into your metaproject. 
 
Assuming the Protégé client access works, next look in your Tomcat\webapps directory for webprotege.jar. Is there also a directory named webprotege? Ensure the jar file is expanded into the directory. You should see a number of directories (such as css, images, …) and files (e.g., WebProtege.html) in the webprotege directory.
 
Also look in Tomcat\logs in  the file catalina.2009-04-17.log and localhost.2009-04-17.log and see if Tomcat is reporting errors.
 
For instance – I get this kind of error in the catalina log when I attempt to run WebProtege and the Protégé server is not running.
 
Apr 17, 2009 1:39:54 PM edu.stanford.bmir.protege.web.server.ProjectManager openProjectRemote
INFO: Loading project Requirements from Protege server 75.66.64.68
Apr 17, 2009 1:39:55 PM edu.stanford.smi.protege.server.RemoteProjectManager getProject
SEVERE: java.rmi.ConnectException: Connection refused to host: 75.66.64.68; nested exception is: 
                java.net.ConnectException: Connection refused: connect
                at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
                at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
                at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
 
When I attempt to run WebProtege and the Protégé server is not running.
 
 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Friday, April 17, 2009 12:04 PM
To: protege-discussion at lists.stanford.edu
Subject: Re: [protege-discussion] WebProtege Installation
 
I am checking it more. You might be right ron. Tomcat is working without any problem but I think it must be either from tomcat or protege server.
 
The reason I am thinking this way because I am using XAMPP for my PHP part and I added tomcat as an add-on. I will try to install tomcat now spereatly and see how I will go. maybe this will solve the problem.
 
I runt he run_protege_server batch file. It's showing me in the last line that Proteger server ready to accept connections... 
 
Does that mean it's working fine.
 
When I open the WebProtege Screen. It's not I can't login. also, I can't see any of the ontologies that shows in the wiki tutorial. That's why I am concentrating on the Protege Server and Tomcat.
 
Best Regards, 
Ahmed
 



From: firedrop84 at hotmail.com
To: protege-discussion at lists.stanford.edu
Date: Fri, 17 Apr 2009 16:09:22 +0000
Subject: Re: [protege-discussion] WebProtege Installation

Thanks Ron.
 
I have installed PHP, MySQL and Apache for some blog that I will try to link it with Webprotege by just providing hyperlink. I shouldn't mention these as I confused things up in my previous email. 
 
Tomcat is working perfectly fine. 
 
I am really getting crazy on how to let it run. I am trying to write a publication and this part is the only part that is left. if it works it means I will have a publication on my topic that the university wiill provide me a ticket to travel to a trip and present my paper in a conference. 
 
Please help. The deadline is very soon and I dont know how to fix it.
 
Best Regards, 
Ahmed
 



From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Mon, 13 Apr 2009 10:36:09 -0500
Subject: Re: [protege-discussion] WebProtege Installation

Ahmed,
 
Have you first ensured that Tomcat is running? Go to http://localhost:8080 and see if the Tomcat administration appears. If not, see if in your Windows Service Manager that the Apache Tomcat service is running. That is at least a starting point.
 
Not sure why you installed PHP and MySQL unless you have some reason beyond Protégé for doing so. Protégé does not require either (although I believe it can use MySQL as a storage backend).
 
Ron 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Sunday, April 12, 2009 4:31 AM
To: protege-discussion at lists.stanford.edu
Subject: [protege-discussion] WebProtege Installation
 
Hi All, 
 
I am trying to install Web Protege in my PC but it's still not working. when I open WebProtege.html it doesn't show me any ontologies or anything. I can't even login even though I created the users.
 
I have installed Apapche, MySQL, PHP, Tomcat, JDK, Protege.
 
I followed the steps in that is described in the following link http://protegewiki.stanford.edu/index.php/WebProtegeAdminGuide
 
The only step that I didn't do was the step that says 
 
If a user launches a Protege client, they are presented with a dialog that requires them to enter the host machine name: 
 
(all the way before it asks to copy the metaproject  file in web pro tege folder.
 
Anyone can help me with this problem.
 
Best Regards, 
Ahmed



See all the ways you can stay connected to friends and family
 



Invite your mail contacts to join your friends list with Windows Live Spaces. It's easy! Try it!



Get news, entertainment and everything you care about at Live.com. Check it out!
_________________________________________________________________
News, entertainment and everything you care about at Live.com. Get it now!
http://www.live.com/getstarted.aspx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20090418/16fc6465/attachment.html>


More information about the protege-discussion mailing list