Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] WebProtege Installation

Firedrop 84 firedrop84 at hotmail.com
Sun Apr 19 05:19:58 PDT 2009


Yep I tried to login using webprotege as username and password and it worked perfectly fine by using Protege and Server but it's not working when I tried to use Webprotege. I think this means that nothing wrong with my Protege Server and it must be Tomcat then.

 

I already coppied the metaproject files from C:\Program Files\Protege_3.4\example\server to c:\xampp\tomcat\webapps\webprotege\projects\metaproject

 

As I am using xampp I installed the tomcat add-on and I noticed that I am using Tomcat 6.0.18. I also noticed that in wiki guidlines says to use tomcat 5.5 (Can the problem be because I am using higher version!).

 

I am not really good in reading the tomcat logs. I checked them but I haven't seen any webprotege errors. Below what I have in the logs for today:-

 

catalina.2009-04-19.log

19-Apr-2009 00:54:38 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
19-Apr-2009 00:54:39 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
19-Apr-2009 00:54:41 org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080
19-Apr-2009 00:57:41 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_13\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
19-Apr-2009 00:57:41 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
19-Apr-2009 00:57:41 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 433 ms
19-Apr-2009 00:57:41 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
19-Apr-2009 00:57:41 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
19-Apr-2009 00:57:43 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
19-Apr-2009 00:57:43 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
19-Apr-2009 00:57:43 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/47  config=null
19-Apr-2009 00:57:43 org.apache.catalina.startup.Catalina start
INFO: Server startup in 2804 ms
19-Apr-2009 19:51:41 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_13\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
19-Apr-2009 19:51:41 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
19-Apr-2009 19:51:41 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 471 ms
19-Apr-2009 19:51:41 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
19-Apr-2009 19:51:41 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
19-Apr-2009 19:51:47 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
19-Apr-2009 19:51:48 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
19-Apr-2009 19:51:48 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/109  config=null
19-Apr-2009 19:51:48 org.apache.catalina.startup.Catalina start
INFO: Server startup in 6859 ms
19-Apr-2009 20:07:37 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
19-Apr-2009 20:07:38 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
19-Apr-2009 20:07:40 org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080
19-Apr-2009 20:08:44 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_13\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
19-Apr-2009 20:08:44 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
19-Apr-2009 20:08:44 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 422 ms
19-Apr-2009 20:08:44 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
19-Apr-2009 20:08:44 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
19-Apr-2009 20:08:46 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
19-Apr-2009 20:08:46 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
19-Apr-2009 20:08:46 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/31  config=null
19-Apr-2009 20:08:46 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1567 ms
19-Apr-2009 20:09:34 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
19-Apr-2009 20:09:35 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
19-Apr-2009 20:09:35 org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080


 

localhost.2009-04-19.log

 

19-Apr-2009 00:54:39 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 00:54:39 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 00:54:39 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 00:54:39 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 00:54:40 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 00:54:40 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 00:57:41 org.apache.catalina.core.ApplicationContext log
INFO: org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: [org.apache.webapp.balancer.RuleChain: [org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: News / Redirect URL: http://www.cnn.com], [org.apache.webapp.balancer.rules.RequestParameterRule: Target param name: paramName / Target param value: paramValue / Redirect URL: http://www.yahoo.com], [org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: http://jakarta.apache.org]]
19-Apr-2009 00:57:41 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 00:57:41 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 00:57:42 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 00:57:42 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 00:57:42 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 00:57:42 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 19:51:41 org.apache.catalina.core.ApplicationContext log
INFO: org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: [org.apache.webapp.balancer.RuleChain: [org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: News / Redirect URL: http://www.cnn.com], [org.apache.webapp.balancer.rules.RequestParameterRule: Target param name: paramName / Target param value: paramValue / Redirect URL: http://www.yahoo.com], [org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: http://jakarta.apache.org]]
19-Apr-2009 19:51:41 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 19:51:41 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 19:51:44 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 19:51:44 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 19:51:45 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 19:51:45 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 20:07:38 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:07:38 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 20:07:38 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:07:38 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 20:07:39 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:07:39 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: [org.apache.webapp.balancer.RuleChain: [org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: News / Redirect URL: http://www.cnn.com], [org.apache.webapp.balancer.rules.RequestParameterRule: Target param name: paramName / Target param value: paramValue / Redirect URL: http://www.yahoo.com], [org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: http://jakarta.apache.org]]
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
19-Apr-2009 20:08:45 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
19-Apr-2009 20:09:35 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()


Can you notice anything. The only thing I noticed which might be the problem is 

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_13

 

Any idea?

 

I started giving up :(. 

 

Best Regards, 

Ahmed
 


From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Sat, 18 Apr 2009 13:11:21 -0500
Subject: Re: [protege-discussion] WebProtege Installation







The error you see is just a warning. I get the same thing. If you connected to the Protégé Server using a Protégé client than RMI is working as expected, since Protégé itself, when running as a client, uses RMI to connect to the Protégé server.
 
Did you modify your metaproject that the Protégé server is using to have a user called ‘webprotege’ per the wiki directions? It can be confusing in that WebProtege involves two metaprojects – the one that WebProtege uses to allow access for users in Tomcat\webapps\webprotege\WEB-INF\. . ., and the other that the Protégé Server uses (normally within your Protégé installation directory path – and not in the WebProtege Tomcat installation directory path).
 
You should be able to confirm the Protégé server side metaproject by using the Protégé client and signing onto the Protégé server using the webprotege user name and password.  WebProtege (via Tomcat) connects to Protégé Server using the user name webprotege. Also, double check your Tomcat log files to ensure that web protégé is not outputting errors of some form. 
 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Saturday, April 18, 2009 11:47 AM
To: protege-discussion at lists.stanford.edu
Subject: Re: [protege-discussion] WebProtege Installation
 
Ron, 
 
when I type in http://localhost:8080/webprotege/WebProtege.html  I can see the webprotege webpage but I can't see any data (such as ontology or anything). Also when I try to login It just basically doesnt login without showing any error message.
 
I tried to login by using Protege and connect by using Protege Server and it worked fine but still I can see I have the rmi error message that I email it in my pervisou email. 
 
 
 
 

 



From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Sat, 18 Apr 2009 10:29:38 -0500
Subject: Re: [protege-discussion] WebProtege Installation

Ahmed,
 
Just to confirm, when you type in http://localhost:8080/webprotege/WebProtege.html nothing appears? You should at least get some kind of error in your browser. Be sure that your browser has JavaScript enabled too. The upper and lower case of the letters is important.
 
When running Protégé in client-server mode, you need to run the batch script run_protege_server.bat to start the Protégé server. You then need one or more clients running. You can use Protégé itself as a client by running run_protege.bat. (WebProtege is also a client). After starting Protégé using run_protege.bat, click on the opening dialog the ‘Open Other’ button. You will be presented an ‘Open Project’ dialog, with buttons on the left that say File, URL, and Server. Pressing the Server button will open a dialog to let you connect to your Protégé Server. This dialog prompts for the server name, and your user id and password setup in the metaproject. If you can successfully connect to your ontology here, then we know that the Protégé server is operating.
 
 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Saturday, April 18, 2009 6:06 AM
To: protege-discussion at lists.stanford.edu
Subject: Re: [protege-discussion] WebProtege Installation
 
Ron, 
 
everything that I installed is on my laptop (Protege, Tomcat, etc). 
 
When I run the run_protege.bat and it opened the protege application. Does Protege Clients means the application. If so, how can I connect to the server when I run the client. 
 
I usually run the run_protege_server.bat to run the protege server and it never ask me for any username or password.
 
I created a small jsp file just to test tomcat and it worked fine. Then, I checked the file that you told me about under webapps directory (webproteg.jar) but I can't find it there or anywhere in my computer.
 
Then, I checked the webprotege folder and I have all the folders such ass css, images, js, etc. Most of the jar files was under lib or WEB-INF\lib but nothing called webprotege.jar.
 
Then I checked the log files that you told me to check and I couldn't find errors. This is what I have in the log files
 
catalina.2009-04-18.log
 
18-Apr-2009 00:33:44 org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/webprotege]
18-Apr-2009 00:44:26 org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
18-Apr-2009 00:44:27 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
18-Apr-2009 00:44:28 org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080

 
localhost.2009-04-18.log 
 
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:27 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()
18-Apr-2009 00:44:28 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()
18-Apr-2009 00:44:28 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextDestroyed()

 



From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Fri, 17 Apr 2009 13:55:46 -0500
Subject: Re: [protege-discussion] WebProtege Installation

Ahmed,
 
If your Protégé Server displays: “Protégé server ready to accept connections. . .” then the Protégé server is running fine. You can verify access and firewall rules by running a Protégé client and connecting to the server itself from the same machine you intend to run Tomcat from. Just run run_protege.bat and connect to localhost using the username and password you put into your metaproject. 
 
Assuming the Protégé client access works, next look in your Tomcat\webapps directory for webprotege.jar. Is there also a directory named webprotege? Ensure the jar file is expanded into the directory. You should see a number of directories (such as css, images, …) and files (e.g., WebProtege.html) in the webprotege directory.
 
Also look in Tomcat\logs in  the file catalina.2009-04-17.log and localhost.2009-04-17.log and see if Tomcat is reporting errors.
 
For instance – I get this kind of error in the catalina log when I attempt to run WebProtege and the Protégé server is not running.
 
Apr 17, 2009 1:39:54 PM edu.stanford.bmir.protege.web.server.ProjectManager openProjectRemote
INFO: Loading project Requirements from Protege server 75.66.64.68
Apr 17, 2009 1:39:55 PM edu.stanford.smi.protege.server.RemoteProjectManager getProject
SEVERE: java.rmi.ConnectException: Connection refused to host: 75.66.64.68; nested exception is: 
                java.net.ConnectException: Connection refused: connect
                at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
                at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
                at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
 
When I attempt to run WebProtege and the Protégé server is not running.
 
 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Friday, April 17, 2009 12:04 PM
To: protege-discussion at lists.stanford.edu
Subject: Re: [protege-discussion] WebProtege Installation
 
I am checking it more. You might be right ron. Tomcat is working without any problem but I think it must be either from tomcat or protege server.
 
The reason I am thinking this way because I am using XAMPP for my PHP part and I added tomcat as an add-on. I will try to install tomcat now spereatly and see how I will go. maybe this will solve the problem.
 
I runt he run_protege_server batch file. It's showing me in the last line that Proteger server ready to accept connections... 
 
Does that mean it's working fine.
 
When I open the WebProtege Screen. It's not I can't login. also, I can't see any of the ontologies that shows in the wiki tutorial. That's why I am concentrating on the Protege Server and Tomcat.
 
Best Regards, 
Ahmed
 



From: firedrop84 at hotmail.com
To: protege-discussion at lists.stanford.edu
Date: Fri, 17 Apr 2009 16:09:22 +0000
Subject: Re: [protege-discussion] WebProtege Installation

Thanks Ron.
 
I have installed PHP, MySQL and Apache for some blog that I will try to link it with Webprotege by just providing hyperlink. I shouldn't mention these as I confused things up in my previous email. 
 
Tomcat is working perfectly fine. 
 
I am really getting crazy on how to let it run. I am trying to write a publication and this part is the only part that is left. if it works it means I will have a publication on my topic that the university wiill provide me a ticket to travel to a trip and present my paper in a conference. 
 
Please help. The deadline is very soon and I dont know how to fix it.
 
Best Regards, 
Ahmed
 < /P& gt; 



From: rcaschultz at gmail.com
To: protege-discussion at lists.stanford.edu
Date: Mon, 13 Apr 2009 10:36:09 -0500
Subject: Re: [protege-discussion] WebProtege Installation

Ahmed,
 
Have you first ensured that Tomcat is running? Go to http://localhost:8080 and see if the Tomcat administration appears. If not, see if in your Windows Service Manager that the Apache Tomcat service is running. That is at least a starting point.
 
Not sure why you installed PHP and MySQL unless you have some reason beyond Protégé for doing so. Protégé does not require either (although I believe it can use MySQL as a storage backend).
 
Ron 
 


From: protege-discussion-bounces at lists.stanford.edu [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of Firedrop 84
Sent: Sunday, April 12, 2009 4:31 AM
To: protege-discussion at lists.stanford.edu
Subject: [protege-discussion] WebProtege Installation
 
Hi All, 
 
I am trying to install Web Protege in my PC but it's still not working. when I open WebProtege.html it doesn't show me any ontologies or anything. I can't even login even though I created the users.
 
I have installed Apapche, MySQL, PHP, Tomcat, JDK, Protege.
 
I followed the steps in that is described in the following link http://protegewiki.stanford.edu/index.php/WebProtegeAdminGuide
 
The only step that I didn't do was the step that says 
 
If a user launches a Protege client, they are presented with a dialog that requires them to enter the host machine name: 
 
(all the way before it asks to copy the metaproject  file in web pr o tege folder.
 
Anyone can help me with this problem.
 
Best Regards, 
Ahmed



See all the ways you can stay connected to friends and family
 



Invite your mail contacts to join your friends list with Windows Live Spaces. It's easy! Try it!



Get news, entertainment and everything you care about at Live.com. Check it out!
 



Get news, entertainment and everything you care about at Live.com. Check it out!
 



Get news, entertainment and everything you care about at Live.com. Check it out!
_________________________________________________________________
News, entertainment and everything you care about at Live.com. Get it now!
http://www.live.com/getstarted.aspx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20090419/4ec25c70/attachment.html>


More information about the protege-discussion mailing list