Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Collaborative Protege server set up solved (?)

adam at wyner.info adam at wyner.info
Sun Jul 19 06:39:45 PDT 2009


Hi,

I appear to have solved the problems with the set up instructions for  
Collaborative Protege.  But test me please.

The instructions as they are inconsistent and confusing (to me and  
others) with respect to which ports to open and what host name to use.  
  I figured it out by trial and error.  I am working on a machine at  
home via a NAT router, but likely anyone who wants to use this behind  
a firewall (which would be everyone) will have similar issues.  The  
localhost (the machine with Protege installed) is 192.168.2.2; the  
router address (the IP address on the web) is 91.85.212.181.  Since  
I'm behind a firewall, I need to port forward.  To experiment, I  
opened several ports on my router to port forward from the router to  
the localhost:  1098, 1099, 5200, 5300.  The first two are defaults  
for rmiactivation and rmiregistry; I'm not sure if the rmiactivation  
needs to be opened; I'm not sure if I need 5200 open either any more.   
I've made changes in the startup script since it is clear from  
starting the server script that it is looking for the registry port of  
1099, not 5200 as in some of the documentation.  Finally, I was not  
clear what the server.hostname should be; now it seems that it should  
be the localhost address.

My current run_protege_server.sh file has the following changes:

HOSTNAME_PARAM=-Djava.rmi.server.hostname=192.168.2.2

PORTOPTS="-Dprotege.rmi.server.port=5300 -Dprotege.rmi.registry.port=1099"

Running the script goes fine.  From within my networ, I can open  
Protege > Open Project > Server > Login as Guest > pick a project  
(newspaper) > the project appears.

Now the test is whether other people outside my LAN can login to the  
same projects and work with them.

A crucial note.  In order for people to collaborate on a project, they  
MUST HAVE THE SAME BUILD (this point was verified by Timothy Redmond).  
  I have Version 3.4.1 (Build 537), which is the current build (as far  
as I know).  If you have another build, this might not work.  Please  
test it with the same build.

To access my machine, I believe that you will have to follow the  
instructions on this page:

http://protegewiki.stanford.edu/index.php/Protege_Client_Server_Tutorial_Setup

At "Connect a Client to the Server", you need to enter the hostname  
for my router 91.85.212.181 (which should then port forward you to the  
network internal machine).  Sign in as Guest with the guest password.   
Select newspaper.  Let me know what happens.  Fingers crossed.

If this works, I'll next try WebProtege, which should avoid some of  
the build compatibility problems.

Cheers,
Adam



More information about the protege-discussion mailing list